Closed Bug 512890 Opened 10 years ago Closed 10 years ago

"ABORT: NULL content node" with SVG filter, em units

Categories

(Core :: SVG, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Assigned: longsonr)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(3 files)

###!!! ABORT: NULL content node: 'aContent', file /Users/jruderman/central/layout/style/nsComputedDOMStyle.cpp, line 376

This abort is part of code added in bug 507067.
Attached file stack trace
Looks like we're trying to resolve em-based units in nsSVGUtils::ObjectSpace without the necessary context (which in this test case is probably the target <rect>).
Attached patch patchSplinter Review
This is consistent with what we do in nsSVGLength2::GetMMPerPixel(nsSVGSVGElement *aCtx) and nsSVGLength2::GetAxisLength(nsSVGSVGElement *aCtx)
Assignee: nobody → longsonr
Attachment #400179 - Flags: review?(roc)
pushed http://hg.mozilla.org/mozilla-central/rev/0754fabcdd2b and http://hg.mozilla.org/mozilla-central/rev/baf6eb94e8f5
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Comment on attachment 400179 [details] [diff] [review]
patch

Simple fix to avoid crash
Attachment #400179 - Flags: approval1.9.2?
Attachment #400179 - Flags: approval1.9.2? → approval1.9.2+
Comment on attachment 400179 [details] [diff] [review]
patch

Don't need this for 1.9.2 if we're not going to land  bug 507067 there.
Attachment #400179 - Flags: approval1.9.2+
You need to log in before you can comment on or make changes to this bug.