align attribute causes browser to crash (html 4.0)

VERIFIED DUPLICATE of bug 50994

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 50994
18 years ago
16 years ago

People

(Reporter: Jesper, Assigned: clayton)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS 5.7 sun4u; en-US; m18) Gecko/20000903
BuildID:    2000090321

Mozilla segfaults when it encounters an html 4.0 document containing
<p align="xxxxx">

This will not happen if you add a closing </p> tag, neither will it crash if you
change the DTD to for example:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.0//EN">

I have reproduced the problem with mozilla 20000903 linux-i686



Reproducible: Always
Steps to Reproduce:
1.Start browser
2.Open file containing example


Actual Results:  Mozilla segfaults

Expected Results:  Mozilla should display an empty page

This code will cause Mozilla mozilla to segfault:


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<p align="center">

--------------------------------------------------

Platforms:
Sun ultra 10 solaris 2.7 gtk 1.2.7
Ppro 200 Slackware 7.0


./run-mozilla.sh: line 29: 22625 Segmentation fault      $prog ${1+"$@"}
This crashes me on Win32, build #2000090408, the Talkback ID is TB16864704Y.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
dup of bug 50994 "Crashing in nsCParserNode::GetNodeType, with strict DOCTYPE
and unclosed tags"

*** This bug has been marked as a duplicate of 50994 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Verified dupe of bug 50994: "Crashing in nsCParserNode::GetNodeType, with strict
DOCTYPE and unclosed tags"
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.