No "Lock-symbol" displayed on the "Envelope-icon" of encrypted mails e. g. in the Inbox

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: dfghjkjhg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

Currently e-mails e. g. in the Inbox do just have a "normal envelope-icon", even if the e-mail is encrypted.

For encrypted e-mails it would be a big gain to have an "envelope-icon with a lock-symbol" (like for secure accounts (SSL) in left-handside account/folder-pane).

Reproducible: Always
(Reporter)

Comment 1

9 years ago
I forgot to mention that there should also be a "pen-symbol" on the envelope if the mail is signed.

Comment 2

9 years ago
that implies that s/mime support is broken in the message header area. Is that a known issue, dmose?
(Reporter)

Comment 3

9 years ago
Created attachment 397271 [details]
Envelope Icons prefixing subject lines
(Reporter)

Comment 4

9 years ago
Hold on ! The message header itself works fine with lock & envelope (instead of a pen) indicating enryption & signature.


What I was wondering was why there's no lock (encryption) & pen (signature) ON THE envelope PREFIXED to each SUBJECT LINE in e. g. the INBOX MESSAGE PANE/LIST.

However after having a closer look onto my current inbox again, I realized that there are no envelopes prefixed to the subject lines at all any more (formerly there where at least opened/closed envelopes prefixed to the subjects indicating read/unread -->  see attachment to my comment #3 which shows an old TB-screenshot).

Very strange... Seems that all subject-envelopes have been removed completely now (only the arrows indicating answered/forwarded are still alive).
That's an interesting idea; what task(s) / use case(s) is it intended to support?  Since it would come at the cost of a bit of visual complexity, it would be interesting to understand when/why would it be helpful to have that information displayed there...

Comment 6

9 years ago
bearing in mind that we don't know if the message is signed/encrypted correctly until you, the user, read it.
Isn't that an implementation detail?  I.e. if we decided that this were truly important, we could presumably verify that stuff at download time, at least for pre-downloaded messages.
(Reporter)

Comment 8

9 years ago
@ Dan / comment #5: You are right. Thinking about again, I agree that there's no "real" advantage having a lock/pen-icon displayed in the subject line - maybe only a "nice to have". The reason for my request was that I was formerly using MS Outlook, WinMail and WinLiveMail and they were all providing this. So I was just wondering why TB doesn't. But again, at the moment I cannot imagin a real advantage from having these icons already displayed e. g. in the inbox - whereas it would be nice to have ...
Closing as WONTFIX.  If someone reading this comes up with an important use case, feel free to add it here and reopen this bug for discussion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.