Last Comment Bug 512968 - Zoom level in COMPOSE window cannot be reset to default 100% (e.g. via exiting/closing and re-opening the window)
: Zoom level in COMPOSE window cannot be reset to default 100% (e.g. via exitin...
Status: RESOLVED FIXED
[fixed by bug 738194][consider follow...
:
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 738194
Blocks: tb-keyboard-tracker 250415
  Show dependency treegraph
 
Reported: 2009-08-27 07:52 PDT by dfghjkjhg
Modified: 2012-09-30 03:11 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description dfghjkjhg 2009-08-27 07:52:11 PDT
User-Agent:       
Build Identifier: Version 2.0.0.23 (20090812)

After slight adjustments in the Thunderbird configuration (about:config --> mousewheel.withcontrolkey.action --> value: 3), the zoom level in all message windows can be changed by keeping down the CTRL-key and scrolling with the mousewheel. Then TB behaves exactly the same way as Firefox does (zooms in/out).


In TB the zoom level will be set back automatically to default (100  %) after exiting a message window or manually after executing the shortcut [Ctrl]+ [0].

This works fine in "NORMAL" message windows e. g. while reading a new mail.
 

Within the COMPOSE WINDOW, zooming via Ctrl + Mousewheel works as well.
  - BUT there's no function behind the shortcut [Ctrl]+ [0], so it doesn’t set the zoom level back to default (100 %).
  - AND exiting the compose window will also not set back the zoom level to default (100 %).

So you will never be able to go back to the default zoom level, because you will never know when you reach 100 % again via Ctrl + Mousewheel, since the Zoom Level isn't displayed anywhere.


--> Therefore [Ctrl] + [0] in TB should also be enabled for setting back the zoom level to default (100 %) in COMPOSE WINDOWs like in other "normal" mail windows (and in FF).

--> Moreover leaving the compose window should also automatically set the zoom level back to default (100 %) like in other mail windows.

Reproducible: Always
Comment 1 Thomas D. (currently busy elsewhere; needinfo?me) 2012-01-07 01:46:26 PST
(In reply to rosaroter-panther from comment #0)

> --> Therefore [Ctrl] + [0] in TB should also be enabled for setting back the
> zoom level to default (100 %) in COMPOSE WINDOWs like in other "normal" mail
> windows (and in FF).

rosaroter-panther, contrary to my expectation, Ctrl++ and Ctrl+- does NOT change the zoom in compose windows, it actually increases/decreases the font size of selected text (Format > Size > Larger/Smaller). Given that, I think the Ctrl+0 part of this bug is currently invalid, because Ctrl+0 should reset the font size then, not the zoom (but we currently don't have Ctrl+0 for resetting font size, which needs a new bug if there isn't one yet).
 
> --> Moreover leaving the compose window should also automatically set the
> zoom level back to default (100 %) like in other mail windows.

That part sounds reasonable and should be confirmed.
Perhaps we can morph this bug and exclude the Ctrl+0 part for composition.

Notwithstanding, I'm wondering if Ctrl++/-/0 is a good shortcut for changing actual font size instead of zoom (in composition), which is inconsistent with the msg reader. Perhaps we should have Ctrl+> and Ctrl+< for the font size (if that's available), to free up Ctrl++/-/0 for the zoom. But that needs more thought, checks, and a new bug.
Comment 2 Thomas D. (currently busy elsewhere; needinfo?me) 2012-01-07 01:52:28 PST
(In reply to rosaroter-panther from comment #0)
> So you will never be able to go back to the default zoom level, because you
> will never know when you reach 100 % again via Ctrl + Mousewheel, since the
> Zoom Level isn't displayed anywhere.

After landing of bug 250415 in TB10, this is a bug, not an RFE.
User has no way of returning to default zoom level of 100% except guessing.
Comment 3 Thomas D. (currently busy elsewhere; needinfo?me) 2012-01-07 03:15:01 PST
Technically, we probably want to change back to the default zoom of 100% when we *open* a new or existing composition.

Current behaviour is unpredictable and confusing:

STR

1) compose msg on current trunk (12), subject: draft1
2) Ctrl+mousewheel to zoom to 300%
3) close & save draft1
4) reopen draft1, check zoom, close
5) Click Write Button for another new msg (draft2), check zoom
6) reopen draft1, check zoom

Current behaviour:

4) after reopening, existing draft has previous zoom value of 300 (this bug, no exact way to reset to 100%), so we pretend to keep the zoom level; however, only until a new draft is created before re-opening an old one.
5) Write new msg always opens with 100% (ok)
6) After 5), any subsequently opened saved drafts will open with 100% (or whatever zoom value was last chosen in another draft).

I don't see a pattern here, anybody?

Perhaps for the time being, always opening draft messages (new or existing) at 100% zoom level would be the best solution. Technically, reset the zoom value to 100% before creating or re-opening drafts.
Comment 4 Thomas D. (currently busy elsewhere; needinfo?me) 2012-09-30 03:11:28 PDT
This has been fixed by bug 738194, after which we'll have an ux-consistent experience of zoom shortcuts (starting from TB18):

Ctrl++ zoom in (everywhere in TB, including composition)
Ctrl+- zoom out
Ctrl+0 reset zoom (now also works in composition - that's the fix for this bug)

Ctrl+< to decrease font size (which needs holding Shift on many keyboards, but we also accept non-shifted shortcut, hence Ctrl+, will work on all keyboards)
Ctrl+> to increase font size (and we also accept Ctrl+.)

The font size shortcuts are also consistent with popular Office applications.

If required, we can deal with the strange and somewhat unpredictable behaviour of *initial zoom* in composition windows elsewhere (as tentatively observed in comment 3; probably related to our old problem of re-using windows). The biggest problem is solved with providing Ctrl+0 for resetting zoom to 100%.

Note You need to log in before you can comment on or make changes to this bug.