Direct URL entry in location bar freezes UI for >15 seconds

RESOLVED DUPLICATE of bug 509048

Status

()

RESOLVED DUPLICATE of bug 509048
9 years ago
9 years ago

People

(Reporter: arancaytar.ilyaran, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20090827 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20090827 Minefield/3.7a1pre

When I visit a site by typing or pasting its URL into the location bar, then Firefox will waste a significant amount of time on (presumably) looking it up in the Places db, /after/ I have pressed Enter.

This manifests in the form of a 15-20 second delay (depending on system load) between the time I press Enter and expect to be taken to the page, and the time Firefox actually sends a request (visible in the throbbers; the location bar throbber stops spinning and the tab throbber appears). The Places lookup is particularly slow as no results are returned, and feels even slower as it disrupts responsiveness without being of any use.

After I press Enter, any Places lookup should be cancelled as it is redundant to look anything up when I already know what I am trying to access.

My current workaround is to enter the URL, then (while the UI is not yet blocked) focus the search engine field, which appears to cancel the Places lookup, then focus the location field again, then press Enter. Fortunately, the Places lookup seems to be triggered only by the "change" event, and with this trick I can bypass it.

Reproducible: Always

Steps to Reproduce:
1. Focus the location bar
2. Paste or type a URL you have never visited before
3. Press enter
Actual Results:  
A significant delay while the browser tries to find the URL in Places.

Expected Results:  
Page should open instantly.

The delay may be particularly severe on my computer due to poor memory (512MB), and becomes noticeably worse when more programs are running or when Firefox has run for a long time and is consuming more memory.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509048

Comment 2

9 years ago
I don't think this is a dupe. I still have this issue on linux uisng the latest trunk nightly
You need to log in before you can comment on or make changes to this bug.