TabSwitching via Ctrl-PageDown/Up must work always, but does sometimes not!

RESOLVED DUPLICATE of bug 78414

Status

()

Firefox
Keyboard Navigation
P1
major
RESOLVED DUPLICATE of bug 78414
9 years ago
9 years ago

People

(Reporter: memex, Unassigned)

Tracking

3.5 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

TabSwitching to another opened tab via Ctrl-PageDown or Ctrl-PageUp must work always, no matter what content (!) is displayed in the tabs. But, unfortunately, Ctrl-PageDown/Up does not switch to another tab if a webpage contains certain content like Flash or Java etc. 

Reproducible: Always

Steps to Reproduce:
1. Open some random tabs to switch through.
2. In one of these tabs, open Bandwidth.com/tools/speedTest and click "Begin Test" (it simply tests your Internet connection speed). 
3. Now try to switch to another tab via Ctrl-PageDown or Ctrl-PageUp: It does not work. 
Actual Results:  
After performing these steps, users cannot switch to another tab via Ctrl-PageDown/Up. 

Expected Results:  
Ctrl-PageDown and Ctrl-PageUp must always (!) switch to another tab, no matter what content is shown in the current tab.  

The webpage Bandwidth.com/tools/speedTest is just one example. There are many more.

Comment 1

9 years ago
This is an issue with any site that has flash content. The Flash takes focus of the keyboard/mouse. To change tabs, click somewhere outside the flash app, and then try it.
(Reporter)

Comment 2

9 years ago
@Sawyer: Shall this be the solution? I don't think so. Most users do not know that they should click "next to" the flash zone. And this is often impossible because the flash app can fill the whole content window. Users want to browse through their tabs fluently; Firefox keyboard shortcuts must have the absolute priority, at least if the mouse pointer "is not over" a flash/etc. object, but outside.
(Reporter)

Updated

9 years ago
Component: General → Keyboard Navigation
Priority: -- → P1
Version: unspecified → 3.5 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 78414
You need to log in before you can comment on or make changes to this bug.