Closed Bug 513165 Opened 11 years ago Closed 7 years ago

remove "Web Search" item from Tools menu

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 25

People

(Reporter: beltzner, Assigned: mkohler)

References

(Depends on 1 open bug)

Details

(Keywords: useless-UI, Whiteboard: [killthem])

Attachments

(1 file)

There's a "Web Search" item in the Tools menu for the off chance that someone has removed the searchbar and closed the window and wants to use the hotkey when the application is focused.

It seems like we should be able to support the shortcut without having a menuItem, which isn't really all that useful (if someone's hidden the search bar, they're the type of user to also know keyboard shortcuts, and not likely to be the type of user to use menuItems)

KILL THEM
Whiteboard: [killthem]
I think the menu item mostly exists so users can learn the keyboard shortcut to focus the search bar.
I've been waiting 4 years for this day. *tear falls*

I've hated that menu item everyday for 4 years and counting.

If beltzner hadn't requested it, it'd never get killed.
OS: Mac OS X → All
Hardware: x86 → All
This would fix bug 242862
(In reply to comment #1)
> I think the menu item mostly exists so users can learn the keyboard shortcut to
> focus the search bar.

That's correct.
(In reply to comment #4)
> (In reply to comment #1)
> > I think the menu item mostly exists so users can learn the keyboard shortcut to
> > focus the search bar.
> That's correct.
Perhaps providing a help menu entry for keyboard shortcuts is a better menu entry alternative then one specifically in the tools menu thats only real purpose is to inform users about a single keyboard shortcut?  Having a menu entry just to inform users about a single keyboard shortcut just doesn't seem justifiable as reason to keep the "web search" entry in the tools menu.
Keywords: useless-UI
In bug 242862 comment 23, Alex says that removing this menu item should address the below problems:

> 1) supporting users who are visually impaired and are relying on a screen
> reader to interact with the browser
> 2) helping people discover the keyboard shortcut for performing a web search
Just to remind everybody, other browsers don't have 'web search' in a menu. Just a search box (or even only in the url box itself).
(In reply to comment #8)
> Looks to not be used very often at all

I don't think anybody said it would be used very often. But see comment 1 and comment 6.
The search field has a nice tooltip, thus i think visually impaired users should be able to find it and have the tooltip read by the reader (MarcoZ could tell us more about discoverability of the search bar).
The shortcut could be added to the tooltip (bug 53309).
Flags: in-litmus?
Attachment #456128 - Flags: review?
Attachment #456128 - Flags: review? → review?(dao)
Assignee: nobody → michaelkohler
Status: NEW → ASSIGNED
Comment on attachment 456128 [details] [diff] [review]
Patch v1 (trivial)

Similar to bug 513168...
The item is needed for exposing the keyboard shortcut.
Attachment #456128 - Flags: review?(dao)
Depends on: 519921
Is this still part of the menus cleanup for Firefox 4?
The issue is making sure the menu items are available when the user has a screen reader activated.  I'm not sure how we detect that, but once we figure it out we can do a full clean up of the traditional menu bar.
Duplicate of this bug: 603491
Assignee: michaelkohler → nobody
Status: ASSIGNED → NEW
It seems to be gone now.
(In reply to Tyler Downer [:Tyler] from comment #16)
> It seems to be gone now.

It's still there. On Windows, you have to use Alt+T to see it as the menuitem is only visible if the Tools menu was opened via keyboard.
Bug 492557 is planning on implementing a single source for teaching users the keyboard shortcuts for various parts of the user interface. When bug 492557 is fixed we should have a good replacement for this menuitem.
Depends on: 492557
Depends on: 896918
Comment on attachment 456128 [details] [diff] [review]
Patch v1 (trivial)

I'll land this along with bug 896918.
Attachment #456128 - Flags: review+
Assignee: nobody → mkohler
https://hg.mozilla.org/mozilla-central/rev/8e453333a110
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
You need to log in before you can comment on or make changes to this bug.