If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Paused downloads disappears after reentering Private Browsing

RESOLVED DUPLICATE of bug 495999

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 495999
8 years ago
8 years ago

People

(Reporter: Vijay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

Download manager fails to list the paused download after reentering the Private Browsing area. Please check "Steps to Reproduce" for clear understanding.

Reproducible: Always

Steps to Reproduce:
I would like to list the steps to follow to recreate the problem...

1. Start Private Browsing
2. Start a Download for any file, pause it before completion
3. Get out of Private browsing -- You can see "One paused download" in status bar
4. Open Tools > Downloads -- You can't see any downloads - I thought, OK it will show in Private Browsing again
5. Start Private Browsing again
6. Open Tools > Downloads -- Woo! I don't have anything in the list.

Actual Results:  
I am left with an "One paused download" in status bar and there is no possible way to get that into the list.


Expected Results:  
Should show the paused downloads in the list so that it can be canceled or restarted.

I did not check it for more than one downloads, if anyone can, you are welcome.
Please note that if you have a paused download inside the private browsing mode, it will be canceled and not remembered when you leave this mode.  That is the whole point of the private browsing mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 495999
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> it will be canceled and not remembered when you leave this mode.  That is
> the whole point of the private browsing mode.

So, it should not then show in Status Bar. I have subscribed to the duplicate now.
You need to log in before you can comment on or make changes to this bug.