lost messages/ empty messages/ corrupted trash?

RESOLVED INVALID

Status

Thunderbird
General
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: caffreyc, Unassigned)

Tracking

({dataloss})

x86
Windows Vista
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [support])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.23 (20090812)

After using your product for years, yesterday I suddenly found some message were completely empty and could not be deleted.  

Some messages produced a message indicating that the message was too big and couldn't be opened and to empty trash - did that.

Some messages would not delete - told that trash was full - to empty it and if that didn't work, compact messages.

Did both.  ALL my messages except 1 disappeared - so I've lost all info prior to 9/27 8:22 pm.  When I ran compact, I was given no option to pick a date range or anything like that.  System went away forever and I finally had to force shut down the program and the system.

Closed TB and reopened.  Downloaded new messages.  Again, some were empty.  Could not delete.  Tried deleting [empty] Trash, closing the program and restarting it.  New, empty trash appear but still could not delete messages.

Checked system recycle bin and emptied that except for one document.  At that point I could delete messages, but the messages I couldn't open before are still blank.  One has no header info at all.  No TO, FROM info.

And all my messages prior to 8/27 pm are GONE.  

Things may be OK now, but I'm really disturbed at the loss of all those messages and about the one I got that are completely empty and cannot be deleted.

I'd appreciate some help clearing this up and making sure part of my system isn't corrupted.  Can I download the latest TB and reinstall that?  If it is the mails that are corrupted, how do I get them deleted?

Thank you.

Cathleen Caffrey


Reproducible: Always

Steps to Reproduce:
1.Click on a message that was blank.  Still blank
2.Try to delete message - can't
3.
Actual Results:  
I described everything I did above.

Expected Results:  
To get some more information about what was going wrong -more suggestions about what to do.  What IS compacting?  What does it actually do?  

If compacting takes a really long time, there should be some icon that keeps moving to show it is still operational.  And one should be able to select a date range for what will be compacted.

I'm totally frustrated with your product.  If I can't trust that my messages will be retained or will come through uncorrupted, I can't trust the product.

If I can't delete SOME message, need to know why and what to do.  Are they affecting each other? new emails? anything else on my hard drive?

HELP
(Reporter)

Updated

8 years ago
Keywords: dataloss
Hi there,
Thank you for your message. Bugzilla is not the place to ask for support , you should go to http://www.mozilla.org/support/thunderbird/ for more help.

That said let's try to figure out what is going on on your machine. You might have reached the mailbox size limit (see http://kb.mozillazine.org/Limits_%28Thunderbird%29) - which could be a reason for you to experience issues. Each mailbox as a database (.msf file) associated with it. This database is used to store information about the emails. When you delete, move an email, the information is not removed from the database. That is what compacting does.

The first thing I would try, would be to rebuild the index of one of the folder causing the issue. You can compact the trash/ rebuild the trash index.
Whiteboard: [support]
Version: unspecified → 2.0
(Reporter)

Comment 2

8 years ago
Thanks for responding to me.  I tried to ask for support and couldn't find an email address.  So I'm very grateful.

Deletion Problem

I finally found out the problem, I think.  And it seems to me to be a bug.

The trash fold showed as empty but when I checked my backup files it showed as 4mb.

So I figured out the path way down into the file folders and found a trash file that was the same size.  I deleted it.

So far no problems deleting.

I hope you (Mozilla) can add a category of "non deleting messages" to the help sections.  Nothing in help even touched this situation.  If you don't do it, please forward it to whoever monitors TB help.  Thanks

EMPTY EMAILS

You didn't respond to the issue of empty emails.  When I went to my ATT Yahoo webmail account, the emails were fine, so it was the process of downloading to TB that caused the problem.

That sounds like a bug to me!  I was unable to find anything in the help that matched this situation and no way to ask for technical support.

GENERAL COMMENT

If there is a corporate person you can pass this on to, I'd appreciate it:  Your help is almost impossible to use.  Until I submitted a problem as a bug I had never gotten a reply in a forum comment that was any use, the help categories are useless for anything beyond a simple basic problem, and there is no "CONTACT US" email for problems that haven't been resolved.  Or at least I couldn't find one.  If you care about quality, an improved help would strengthen your image and your support greatly.

Cathleen Caffrey
Santa Rosa, CA

Updated

8 years ago
Duplicate of this bug: 513693
Can you try deleting Trash, Junk, Trash.msf, Junk.msf?

See if this can help you http://forums.mozillazine.org/viewtopic.php?f=39&t=746215&start=0&st=0&sk=t&sd=a
Hi Cathleen:

Thanks for taking the time to file a bug report. Unfortunately this is 
not a bug but a support request and bugzilla isn't the place to file 
support requests.

The place we recommend for Thunderbird support is: 
http://getsatisfaction.com/mozilla_messaging

In particular, these Get Satisfaction topics:
http://getsatisfaction.com/mozilla_messaging/topics/cant_delete_messages - Can't delete email
http://getsatisfaction.com/mozilla_messaging/topics/some_e_mails_show_blank_some_show_wrong_content_compared_to_title_sender - Emails blank from ATT Yahoo account

has information that I believe are pertinent to your support request. Please join us at Get Satisfaction and reply on these topics or feel free to start a new support topic. QA: please close this bugzilla bug.

Cheers
....Roland "recently hired technical support lead"  Tanglao 
on behalf of the Thunderbird Bugzilla and Support Community
I've created a Get Satisfaction topic for this at:

http://getsatisfaction.com/mozilla_messaging/topics/lost_messages_empty_messages_corrupted_trash

Pleae join us at Get Satisfaction and continue the discussion there.
(In reply to comment #6)
> I've created a Get Satisfaction topic for this at:
> 
> http://getsatisfaction.com/mozilla_messaging/topics/lost_messages_empty_messages_corrupted_trash
> 
> Pleae join us at Get Satisfaction and continue the discussion there.

...in the meanwhile closing invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

8 years ago
Follow-up to my previous communications.

I got new updates for tbird and for my spyware software. The frequency of the problem has decreased, but still happens.

Deleting trash does not delete the 4 gig file called trash. I have to follow a VERY LONG path (myuserid/appdata/roaming/thunderbird/profiles/1qspwocv.default//mail/pop.att.yahoo.com) to see TRASH (no extension) and TRASH.MSF. If I delete TRASH, which has become over 4 gigs, then deletion can proceed as usual. This is the only thing that works.

To add to the confusion, I recently received a bunch of messages which had the subject and message content mixed up - different subject from content. (I saved a few of those if anyone wants to see them). Put them in a separate folder called "bizarre".  (The messages were fine when I looked at them at the att.yahoo site).

A few days later, suddenly a whole bunch of messages that I'd previously deleted, plus some of the ones that came in empty earlier, reappeared. Sometimes 2-3 copies. There were also a bunch of empty messages dated 12/31/89. When I deleted duplicates, sometimes a new empty message with the 89 date appeared. I cleared out ALL the wierd messages.

Since then the only problem appears to be the occasional corruption of TRASH.

Any more info on your end?

Cathleen
You need to log in before you can comment on or make changes to this bug.