svg: mouse events on use-element are not redirected to the used-element (in case latter one has event handlers)

RESOLVED DUPLICATE of bug 265895

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 265895
9 years ago
8 years ago

People

(Reporter: David Trallero Mena, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

in SVG, when there is a use element, the pointer events are not redirected to the referenced element (assume there are event handlers) IF the event handler was set by JS. BUT it works if the event is set as an attribute (onmousedown=something).

I will attach an example of this.

Reproducible: Always

Steps to Reproduce:
1.Click on the blue rectangle
2.Click on the red rectangle. No dialog box appears.
3.


Expected Results:  
Should a dialog box appear?
(Reporter)

Comment 1

9 years ago
Created attachment 397535 [details]
All instructions with-in the file
Component: General → SVG
Product: Firefox → Core
QA Contact: general → general
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265895
You need to log in before you can comment on or make changes to this bug.