If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

If I try to open up Internet Explorer 8.0, home page for internet explorer automatically opens in firefox

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: nww999, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-1], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

I recently downloaded firefox version 3.5. It automatically was set to be my default browser without my consent. When I try to open up internet explorer 8.0, it automatically opens up in firefox. I am extremely distressed by this being some websites I view will not work with just firefox. An exmaple website is http://www.hauntingechoes.com/index.php. When one tries to log in, the user is not truly logged in. The problem is firefox being it works on other internet browsers.

I need internet explorer for some school projects. Firefox just won't cut it with the current settings. I have tried about all ways to get Firefox to STOP being the default browser, but it refuses to not be the default browser. This is a major issue.

Reproducible: Always

Steps to Reproduce:
1.Click on the button to open up internet explorer with Firefox version 3.5 previously installed
2. Whatever the homepage set for internet explorer will appear in Firefox and NOT in an internet explorer window
Actual Results:  
When I attempt to open up internet explorer, firefox automatically popped up instead of internet explorer window

Expected Results:  
The default browser should be internet explorer NOT Firefox when the computer is set to have Internet Explorer as its default browser
If you go to Start->Run and type "iexplore" into the run dialog, does it still open up Firefox?

If so, I would suggest uninstalling Firefox.  That should never happen, not even with the "Make Firefox the default browser" setting enabled.

Comment 2

8 years ago
I have the same problem,i told them about but i don't think they care , is this like Bug 506441 ?

Comment 3

8 years ago
If i go and select open with internet explorer it's opening with firefox or
tell me to download file,see pic.

Comment 4

8 years ago
Created attachment 397622 [details]
the problem
(In reply to comment #2)
> I have the same problem,i told them about but i don't think they care , is this
> like Bug 506441 ?

Please follow the same instructions from Comment 1.  When you run IE from the command line you should be able to set IE to be the default browser again.

Comment 6

8 years ago
The problem is that i don't wish ie as default browser,files associated with firefox can't be opened with ie this is a bug,this is the problem.

Comment 7

8 years ago
This problem is not in 3.0.14 ,it's working fine,only this stupid beta 3.5.2 is very f***cked up
Firefox does not set itself as default without your permission, there is a checkbox on the install dialog that asks, you just didn't unckeck it.

If you go to the control panel, programs and features, then set program access and deafults, you should be able to reset IE to deafult. see if that helps.

Black P, 3.5.2 is a final version, not beta.

Comment 9

8 years ago
I know it's not a beta because of this many bugs i call it a beta ,anyway it's the best from the world..but it has some critical problems.Thanks and keep up the good work.
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.