Firefox won't work across multiple X11 screens or displays

RESOLVED DUPLICATE of bug 125482

Status

()

RESOLVED DUPLICATE of bug 125482
9 years ago
9 years ago

People

(Reporter: a.nielsen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.2) Gecko/20090830 Gentoo Firefox/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.2) Gecko/20090830 Gentoo Firefox/3.5.2

If you run multiple X11 screens or displays (so you *can't* drag windows between screens) then all Firefox windows have to be on the first screen you load it on - you can't have windows spread across all your screens.

In fact, if you try to run Firefox from a different screen it pops up with an error: "Firefox is already running, but is not responding.  To open a new window, you must first close the existing Firefox process, or restart your system."

Reproducible: Always

Steps to Reproduce:
1. Load X11 with two screens or displays (see http://maketecheasier.com/run-multiple-x-sessions-without-virtualization/2009/07/11 for loading two X11 displays on one PC with one monitor - in short, "startx && startx -- :1")
2. Load Firefox on one screen (:0.0)
3. Load Firefox on another screen (:0.1) or display (:1.0)
4. Observe the error message on the second load attempt

Actual Results:  
Popup error

Expected Results:  
Another browser window would open on the other X11 screen

This can be done using two different profiles, but having separate bookmarks etc. on each monitor isn't a great solution.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 125482
You need to log in before you can comment on or make changes to this bug.