The default bug view has changed. See this FAQ.

Deprecate isReady() in geolocation provider

RESOLVED FIXED

Status

()

Core
Geolocation
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Martin McNickle, Assigned: Martin McNickle)

Tracking

({dev-doc-complete})

unspecified
dev-doc-complete
Points:
---

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: 

isReady() isn't used by the geolocation code at all so serves no purpose. Also from discussion:

<dougt> i would be happy to declare isReady as deprecated right now. ;-)

Reproducible: Always
(Assignee)

Comment 1

8 years ago
Created attachment 397604 [details] [diff] [review]
patch

Removed isReady from the idl file. Updated interface UUID. Removes isReady implementations from the bundled providers too.

Will update the docs at https://developer.mozilla.org/En/nsIGeolocationProvider when it lands. Is there anything special to write in the docs to say this was removed (when where why? etc?).
Attachment #397604 - Flags: review?(doug.turner)
Assignee: nobody → mmcnicklebugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

8 years ago
Attachment #397604 - Flags: review?(doug.turner) → review+

Comment 2

8 years ago
http://hg.mozilla.org/mozilla-central/rev/67a8b17ad2a1

Thanks!!

> Is there anything special to write in the docs to say this was
removed (when where why? etc?).

This was removed because developers found it not required.  (that works for me.  You can also mention this bug).
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Attachment #397604 - Flags: approval1.9.2?

Updated

8 years ago
Attachment #397604 - Flags: approval1.9.2? → approval1.9.2+

Updated

8 years ago
Keywords: checkin-needed
This patch doesn't apply on 1.9.2.
Keywords: checkin-needed
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/540244d8dbb7
status1.9.2: --- → beta1-fixed
Documentation updated:

https://developer.mozilla.org/en/XPCOM_Interface_Reference/NsIGeolocationProvider
Keywords: dev-doc-complete
You need to log in before you can comment on or make changes to this bug.