"ASSERTION: nsClassifierCallback::Run() called while a channel is still suspended.: '!mSuspendedChannel'"

RESOLVED INVALID

Status

()

Toolkit
Safe Browsing
RESOLVED INVALID
9 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
I hit this once and couldn't reproduce. Any idea what could have caused this?

###!!! ASSERTION: nsClassifierCallback::Run() called while a channel is still suspended.: '!mSuspendedChannel', file /Users/jruderman/central/docshell/base/nsDocShell.cpp, line 10290
nsClassifierCallback::Run() (nsUnicharUtils.cpp:)
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessNextEvent_P(nsIThread*, int)
nsThread::Shutdown()
NS_InvokeByIndex_P
nsProxyObjectCallInfo::Run()
nsThread::ProcessNextEvent(int, int*)
NS_ProcessPendingEvents_P(nsIThread*, unsigned int)
nsBaseAppShell::NativeEventCallback() (/var/tmp/gcc/gcc-5465~16/src/gcc/libgcc2.c:)
nsAppShell::ProcessGeckoEvents(void*) (/var/tmp/gcc/gcc-5465~16/src/gcc/libgcc2.c:)
CFRunLoopRunSpecific (/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation)
CFRunLoopRunInMode (/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation)
RunCurrentEventLoopInMode (/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox)
ReceiveNextEventCommon (/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox)
BlockUntilNextEventMatchingListInMode (/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox)
_DPSNextEvent (/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit)
-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] (/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit)
-[NSApplication run] (/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit)
nsAppShell::Run() (/var/tmp/gcc/gcc-5465~16/src/gcc/libgcc2.c:)
nsAppStartup::Run() (/Users/jruderman/central/toolkit/components/url-classifier/src/nsUrlClassifierUtils.h:)
XRE_main (nsProfileLock.cpp:)
main
_start
start
(In reply to Jesse Ruderman from comment #0)
> I hit this once and couldn't reproduce. Any idea what could have caused this?

Nope!

But this code has changed significantly, and docshell doesn't even call nsClassifierCallback::Run(). So this bug is likely dead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.