Mismerge causes issues in animated images

RESOLVED FIXED

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: joe, Assigned: joe)

Tracking

({verified1.9.2})

Trunk
x86
Mac OS X
verified1.9.2
Points:
---

Firefox Tracking Flags

(blocking1.9.2 needed, status1.9.2 .2-fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 397693 [details] [diff] [review]
add back braces

In bug 753, I accidentally removed a pair of braces, which causes some problems (at worst, some extra drawing, I think). This patch restores those braces.
Attachment #397693 - Flags: review?(bobbyholley)
Comment on attachment 397693 [details] [diff] [review]
add back braces

Given the indentation I have trouble really comprehending what we're doing on trunk right now, but this patch certainly looks right. r=bholley
Attachment #397693 - Flags: review?(bobbyholley) → review+
(Assignee)

Comment 2

9 years ago
http://hg.mozilla.org/mozilla-central/rev/a1c45ec0d5d5
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 538752
Comment on attachment 397693 [details] [diff] [review]
add back braces

This patch fixes the animated gif corruption people have been seeing. I'll see if I can get some sort of test together for it (this could be quite tricky)
Attachment #397693 - Flags: approval1.9.2.1?

Updated

9 years ago
Duplicate of this bug: 541686
(Assignee)

Comment 6

9 years ago
This is an ultra-safe fix that should have made it into 1.9.2, and we shouldn't accidentally leave a bunch of animated images broken for 3.5.2.
blocking1.9.2: --- → ?
(Assignee)

Comment 7

9 years ago
Here is what happens:

We have a GIF image whose first frame does not cover the full container. Its disposal specifies "Keep." The next frame is smaller still than the first frame, so some of the first frame should show through. But since the GIF is not disposing properly because of the incorrect bracing, it should get a blank background instead.

I think this is the only symptom, other than extra drawing, that should result from this bug. But I've been wrong before: see comment 0.
blocking1.9.2: ? → ---

Updated

9 years ago
Duplicate of this bug: 543192

Comment 9

9 years ago
aFrameToUse doesn't serve any purpose anymore, does it?
Duplicate of this bug: 546186

Comment 11

9 years ago
This Bug has not been fixed.  I am the author of Bug 546186.
(Assignee)

Comment 12

9 years ago
I can't check it in until I get approval.

Comment 13

9 years ago
Joe, could you please take a look at animation bug 546272?
Attachment #397693 - Flags: approval1.9.2.2? → approval1.9.2.2+
b+a1.9.2=beltzner
blocking1.9.2: --- → needed

Comment 16

9 years ago
(In reply to comment #15)
> http://hg.mozilla.org/releases/mozilla-1.9.2/rev/0a4e39d6cb7e

Is this a fix to this problem?  If so, will this fix be added to the next update of Firefox?
(Assignee)

Comment 17

9 years ago
Yes.
Duplicate of this bug: 551611

Updated

9 years ago
Duplicate of this bug: 552356

Updated

9 years ago
Duplicate of this bug: 552907
I've verified that 546186 is fixed in 3.6.2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2pre) Gecko/20100315 Namoroka/3.6.2pre (.NET CLR 3.5.30729)).

Is that enough to verify this fix or is there another way to verify this?
Keywords: verified1.9.2

Updated

9 years ago
Assignee: nobody → joe
(Assignee)

Comment 22

9 years ago
That's enough to verify this fix.

Comment 23

9 years ago
The bug still exists for me. I have seen people claiming it was fixed for them viewing the same images as I have, but for some reason there's a difference between us.

I've also tested with this image (taken from a bug which is a duplicate of this one):
http://www.startrekitalia.com/publicnew/avatars/dracon.gif

I see no animation in the animated gif above. Here are the version details that I'm using (taken from Help -> About):
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2

Just in case, I tried the usual stuff: clear cache, restart etc. Any idea why it's still borked for some of us?

Thanks..

Comment 24

9 years ago
Ok, some more info about the problem I've reported earlier, that might help shed some light on the source of the problem:

I have 2 profiles on my Firefox: the default one and and secondary one. I'm using the secondary one for most of my browsing. I have a shortcut I'm using to start FF with the secondary account, using the following command line:

   "C:\Program Files\Mozilla Firefox\firefox.exe" -p other_profile_name

1. When using this secondary profile gifs are *not* being animated correctly!
2. When I use the default profile the same animated gifs are animated correctly.
3. I've started a new (3rd) profile and animated gifs are working correctly there.

I'm not sure why this difference occurs, but it is happening to me consistently. Perhaps the upgrade somehow needed to update the profiles and failed to do so on my secondary profile? If that's the case, is there any way to fix it manually?

Thanks..

Comment 25

9 years ago
Another update:

I found what was causing the error, but I have no idea how that situation occurred. After I realized it was a profile issue (see previous post), I started checking the settings inside my profile. I found the in prefs.js I had the following setting:

   user_pref("image.animation_mode", "none");

That looked suspicious so I removed it and animated gifs started working again!

Now that's the first time I've ever noticed that setting and I've never ever touched it before. Only a speculation here, but is it possible that FF 3.6.0 somehow added this, causing animated gifs to stop working, then during the upgrade to 3.6.2 this setting was supposed to be removed but due to an issue in the upgrade process was only removed in the default profile?

Anyway, that's my resolution of the issue. Hope it helps anyone ;)
(Assignee)

Comment 26

9 years ago
Nope, that's been there forever, but there's lots of reasons why you might've had that set - extensions, experimenting with other settings (and subsequently forgetting about it!), etc.

Comment 27

9 years ago
I haven't experimented with any setting in at least 6 months, probably more, and certainly not with that particular setting.

Anyway, that was just my assessment of the situation. If no one else confirms that this issue was actually reproduced for them then I agree that it's some sort of issue in my environment, although I honestly can't see how it could've happened specifically in my environment.
You need to log in before you can comment on or make changes to this bug.