Customized Persona get not ported over into the customized build.

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
4 years ago

People

(Reporter: cbook, Assigned: myk)

Tracking

Details

Comment hidden (empty)
(Reporter)

Comment 1

9 years ago
in my testbuild http://dm-partnerdist01.mozilla.org:82/~lorchard/byob2/profiles/Tomcat/browsers/YyOTMxMjgyMA/distribution.ini i selected the lady gaga persona http://getpersonas.com/persona/830 for this build.

In the Windows Build i tested is the default persona actived and not as expected the lady Gaga one ?
(Reporter)

Comment 2

9 years ago
btw the value in the distribution.ini is extensions.personas.initial="{\"id\":\"830\",\"name\":\"Lady Gaga\",\"accentcolor\":\"#000000\",\"textcolor\":\"#ffffff\",\"header\":\"3\\/0\\/830\\/Persona_Header_UNI_GAGA_FINAL_2.jpg\",\"footer\":\"3\\/0\\/830\\/Persona_Footer_UNI_GAGA_FINAL.jpg\"}"

Comment 3

9 years ago
This is caused by the extension, specifically the issue outlined in bug 503300, so 1.2.2 didn't address it, as groovy blue still trumps what's set in distribution.ini. Adding Myk to the thread for comment on the work-around.

Work-around: modify the personas extension such that the last line in extensions\personas@christopher.beard\defaults\preferences\personas.js is commented out so that extensions.personas.initial is not set. On first-run, the personas extension reads the value from distribution.ini and writes it to extensions.personas.current, so that the default persona defined in distribution.ini will carry-over in the event of an upgrade of the extension.

Tests required: Tomcat - need to validate that an extension update will not fail because of the modified extension (i.e. modifying the file above will have no adverse effects on the next release).
Not sure what the resolution is / will be on this... Is there a fix in the works for the addon?  Otherwise, I might need to look into some way to make BYOB patch
 addons it downloads from AMO, since the addons themselves aren't in SVN and getting IT to manually tweak a downloaded addon on a prod server might be a hairy request
(Assignee)

Comment 5

9 years ago
I just talked to Dan about this, and he helped me figure out the solution to this problem.  Taking for implementation.
Assignee: nobody → myk
Status: NEW → ASSIGNED
(Assignee)

Comment 6

9 years ago
I committed a fix for this bug to the trunk as changeset http://hg.mozilla.org/labs/personas/rev/d5a6a876d27f.  I committed a fix to the branch as changeset http://hg.mozilla.org/labs/personas/rev/ea73c5b21abd.

I've also spun builds that can be used to test the fix.

Trunk development build:

https://people.mozilla.com/~cbeard/personas/dist/personas-dev.xpi

Version 1.2.3 release candidate:

https://people.mozilla.com/~cbeard/personas/dist/personas-v1.2.3rc1.xpi

I've tested the non-BYOB functionality, and it works as expected.  The initial persona is Groovy Blue if I install the extension as if directly from AMO; if I install it as if from a persona detail page in the gallery, it is that persona.

Could someone test BYOB with this fix?

Resolving this fixed speculatively, but please reopen if the initial persona specified in the distribution.ini file of a BYOB build is still not getting set on first run.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

9 years ago
(In reply to comment #6)
 
> Could someone test BYOB with this fix?
> 
> Resolving this fixed speculatively, but please reopen if the initial persona
> specified in the distribution.ini file of a BYOB build is still not getting set
> on first run.

will do !
(Reporter)

Comment 8

9 years ago
verified ! Thanks guys !
Status: RESOLVED → VERIFIED
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.