Setting start date=end date=vote cap date=<today>,shows an incorrect error message

VERIFIED FIXED in 1.2

Status

Websites
creative.mozilla.org
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: krupa, Unassigned)

Tracking

unspecified
x86
All

Details

Attachments

(5 attachments)

(Reporter)

Description

8 years ago
Created attachment 397716 [details]
user message

steps to reproduce:
1.Log into your AMO account
2.Create a challenge with start date=end date=vote cap date=<today>[i.e aug 31,2009]
3.Go to http://mcc.stage.mozilla.com/challenges
4.Click on the newly created challenge.
5.notice the user message

expected result:
either challenges with start date=end date=vote cap date are not allowed OR they are handled so that user can still submit designs

actual result:

User message incorrectly shows-"This challenge ended August 31, 2009."
(Reporter)

Comment 1

8 years ago
Created attachment 397720 [details]
all dates set to today

However I was unable to reproduce this behavior
Created attachment 397742 [details]
Challenge Screenshot 

Could not reproduce.  See attachment.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

8 years ago
I was able to reproduce this behavior following the steps described in comment#0.
see: http://mcc.stage.mozilla.com/challenges/31

reopening...
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

8 years ago
Created attachment 398223 [details]
able to reproduce-09/02
setting challenge end day as next day still show the message that challenge ended.
For e.g. I created this challenge (http://mcc.stage.mozilla.com/challenges/43) with the following values:
start date: sept 2 2009 (today)
end date: sept 3 2009 (day after current day)
vote cap end date: sept 4 2009 (two days after current day)

when I go to the challenges details page (http://mcc.stage.mozilla.com/challenges/43) it gives me 'this challenge ended sept 3 2009'.
Created attachment 398260 [details]
challenge ended sept 3
(Reporter)

Comment 7

8 years ago
STR:
1.Have an existing challenge which has vote date to <today>
2.Create a new challenge with all the dates set to <today>
3.Check the challenge detail page for the new design.

observed behavior:
The new challenge detail page will have the incorrect user message.

additional info:
The bug happens only when there are overlapping dates.Editing them will solve the problem.


As this happens only when there are two challenges with overlapping vote cap dates.it can be addressed in 1.2
Target Milestone: 1.1 → 1.2
Displayed message now reads:

==

Uh oh! Something went wrong...

    * Another design challenge falls within this date range. De-activating this design challenge to prevent conflict on site.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

8 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.