Open Bug 513780 Opened 11 years ago Updated 1 year ago

Yahoo Mail mailto (web protocol) handler is broken (mail.yahoo.com)

Categories

(Web Compatibility :: Desktop, defect, P5)

defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: zzxc, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: parity-ie, webcompat:site-wait, Whiteboard: [3.6+] [platform-rel-Yahoo!] [sitewait])

The Yahoo Mail web protocol handler, accessed when mailto is set to "Use Yahoo Mail" in Applications, appears to be broken.  The entire mailto: URL is ending up in the "To" message field, rather than being parsed as expected.

STR:
1. Log into Yahoo Mail
2. Go to http://www.mozilla.org
3. Open File->Send link
4. A new message is composed, with "mailto:?body=http://www.mozilla.org/" in the To field.
Is Yahoo aware of this issue?  This works as expected for Internet Explorer users.
Whiteboard: [parity-IE]
I don't believe they are, as this was working when we launched 3.0, but it looks like there's been a change in handling since it was implemented, as it's definitely broken for any complex mailto's (essentially anything that has more than a to: and cc:). Is ctalbert's mailto testcase part of the general testing we do?

I'll reach out to the Y! mail team on this.
The Yahoo! Mail team is aware now, and has confirmed they're seeing the same thing we are. They're looking into it, and I'll update the bug when I have more info.
Duplicate of this bug: 530616
i am copying over from bug 530616:

set options->applications->mailto to yahoo mail
goto http://forums.mozillazine.org/viewtopic.php?f=9&t=1607655
file->send link

this gives in the NEW yahoo mail:
to: (empty)
cc: (empty)
subject: (empty)
body:
http://forums.mozillazine.org/viewtopic.php'>http://forums.mozillazine.org/viewtopic.php'>http://forums.mozillazine.org/viewtopic.php

and in CLASSIC yahoo mail:
to: mailto:?body=http://forums.mozillazine.org/viewtopic.php?f=9&t=1607655
cc: (empty)
subject: (empty)
body: (empty)

should be (as it works on gmail):
to: (empty)
cc: (empty)
subject: problem sending link with yahoo mail • mozillaZine Forums
body: http://forums.mozillazine.org/viewtopic.php?f=9&t=1607655

my builds:
1. Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
2. Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3 (.NET CLR 3.5.30729)
3. Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.9.3a1pre) Gecko/20091121 Minefield/3.7a1pre (.NET CLR 3.5.30729)
We don't have a blocking flag on this bug, so adding [3.6+] to the whiteboard.
Whiteboard: [parity-IE] → [parity-IE][3.6+]
so is this supposed to block?
It can't block if it should be fixed by the Yahoo team but the parity-IE flag suggests otherwise.  Beltzner, can you move it to the right component if Tech Evang isn't it?
They are working on it, and agree it's broken. No ETA on a fix, though.
i just tested it on Mozilla Developer Preview 3.7a1
yahoo classic mail does not even open a new message, just stays on the main page.
may we change the product from "tech evangelism" to "firefox" so we may request blocking of 1.9.3?
beltzner added [3.6+] to the whiteboard at the time, but that did not seem to help...

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1) Gecko/20100208 MozillaDeveloperPreview/3.7a1 (.NET CLR 3.5.30729)
I think this remains an evangelism issue, as the UA parsing by Yahoo! is the issue here, not that the mailto protcol handler is broken for the preview. worse end result, but a different problem.

I'll ping the folks I know, as this could bite us in the behind later. I just wish the UA detection actually did use "and higher" logic.
i think at this stage we should reverse engineer the issue, to have an in-house solution for version 4.
disagree. changing the product to deal with a broken web service seems like the wrong way to do things.

Should we consider removing Yahoo! Mail from the list of defaults? I'll ping the Y! Mail team again and ask if there's any ETA for a fix, but if it's not going to support mailto's properly, we should remove it from the list.
Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100825 Minefield/4.0b5pre (.NET CLR 3.5.30729)

in yahoo NEW mail, body is now correct. title is still missing.
no change for yahoo CLASSIC mail
Is this bug a duplicate of bug 426260?
There is an open source program for Windows called Gmail Default Maker.  Despite the name, it works with other services including Yahoo.  Its purpose is to allow a webmail composer to be the default mailto handler.

I have tried it with both the Classic and newer Yahoo, and it works perfectly with both.  In Firefox, I selected File/Send Link.  A new tab opened with a Yahoo login screen.  When I logged in, a composing screen opened with the subject and body populated exactly as they should be.

As I said, the program is open source.  So it seems reasonable that you could review the code amd figure out what they are doing right that the internal Firefox function is doing wrong.

The program's home page is:

http://gmaildefault.codeplex.com/
yahoo new mail now works fine for both title and body
yahoo old mail opens in inbox and does not open the mail composer at all
Version: unspecified → Trunk
Duplicate of this bug: 539871
Depends on: 426260
Yahoo have started popping up a prompt to add a mailto protocol handler. Some people have no idea what the message means and refuse to click the "Add Application" button. They then complain that the message pops up every time they open their inbox.
https://support.mozilla.org/questions/994658
https://support.mozilla.org/questions/994725
https://support.mozilla.org/questions/994965
http://forums.mozillazine.org/viewtopic.php?f=38&t=2819927

Please replace the existing entry with the one provided by Yahoo. Below is the information as added by the aforementioned prompt.

Yahoo!
https://us-mg6.mail.yahoo.com/neo/launch?action=compose&To=%s
https://us-mg6.mail.yahoo.com/favicon.ico

On a related note, 6 YEARS wasn't enough time to add an icon to the Yahoo! Mail entry?
Bug 428905
(In reply to Gingerbread Man from comment #19)
> Please replace the existing entry with the one provided by Yahoo. Below is
> the information as added by the aforementioned prompt.
> 
> Yahoo!
> https://us-mg6.mail.yahoo.com/neo/launch?action=compose&To=%s
> https://us-mg6.mail.yahoo.com/favicon.ico

For what it's worth, I'm getting connected to a different server: 
https://us-mg4.mail.yahoo.com/neo/launch?action=compose&To=%s

I'm not sure we know the most universal address for Yahoo mail (other than the classic redirector).
(In reply to Jefferson from comment #20)
> For what it's worth, I'm getting connected to a different server: 
> https://us-mg4.mail.yahoo.com/neo/launch?action=compose&To=%s

I suppose there's even more difference when it comes to non-English Yahoo sites, so the suggestion at comment 19 may be a dead end. I filed a separate bug report for the issue of annoying "Add Application" prompts:
Bug 998427
Assignee: english-us → nobody
Component: English US → Desktop
The original issue here is fixed, emailing a link it displays properly in Yahoo mail now. The other issue described is being tracked in bug 668577. Closing this bug.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
it is still broken for the basic setting version of yahoo mail.
the link does not get copied to the body in that case
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
platform-rel: --- → ?
Whiteboard: [parity-IE][3.6+] → [parity-IE][3.6+] [platform-rel-Yahoo!]
eyal,

I'm pretty sure that Yahoo! will not fix the old UI of Yahoo! Mail as they invested time into developing the new one. I'm asking our contact at Yahoo!

But do not keep your hopes high.
Whiteboard: [parity-IE][3.6+] [platform-rel-Yahoo!] → [parity-IE][3.6+] [platform-rel-Yahoo!] [sitewait]
platform-rel: ? → ---
From Yahoo!

> they are tracking it under MAILFE-30017. I will keep you updated with any progress.
> The mail team is encouraging users on unsupported / really old browsers, to use the full featured mail product, where this functionality already works. 
> Since all the investment is going towards the full featured mail product these days, there is of course a lower priority for this particular bug. That said, we'll do our best and I will keep you posted!
Priority: -- → P5
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Keywords: parity-ie
Whiteboard: [parity-IE][3.6+] [platform-rel-Yahoo!] [sitewait] → [3.6+] [platform-rel-Yahoo!] [sitewait]
Product: Tech Evangelism → Web Compatibility

See bug 1547409. Moving webcompat whiteboard tags to keywords.

You need to log in before you can comment on or make changes to this bug.