Remove Cookies button is not cleared when cookie list is cleared

NEW
Unassigned

Status

()

Firefox
Preferences
8 years ago
6 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill][mozmill-test-blocked], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Build Id: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a2pre) Gecko/20090831 Namoroka/3.6a2pre ID:20090831034605

and 

Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

Steps to Reproduce:
1. Go to the privacy pane
2. Click on custom settings and go to the cookies manager
3. Empty out the list of cookies 
4. uncheck "Accept cookies from sites" as well
5. Go to any site and open up the preferences dialog
6. go to the cookies manager

Actual results:
The list of cookies is empty, but the "remove cookies" button is enabled.

Expected Results:
The list of cookies is empty and the "remove cookies" button is disabled.
(Reporter)

Updated

8 years ago
Blocks: 513822
This bug affects one of our Mozmill tests. We have a workaround for now but I wonder if we can get this fixed.

Daniel, do you know who owns the cookies ui in the preferences manager?
Whiteboard: [mozmill][mozmill-test-blocked]

Comment 2

8 years ago
No one, really. Sounds trivial. You could probably see if Ehsan or Paul feel like fixing it...
Created attachment 434414 [details] [diff] [review]
Patch v0.1

BAM! I think that's all that's needed, but I haven't looked at that code until just now, so perhaps I'm missing some cases. I hand tested the cases i could think up and all looked fine.
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #434414 - Flags: review?(dwitte)

Comment 4

8 years ago
Comment on attachment 434414 [details] [diff] [review]
Patch v0.1

Hmm. Isn't this bug about "removeCookies", not "removeAllCookies"?

From code inspection, (and I'm guessing here), it looks like we never disable "removeCookies" in _loadCookies() if the list is empty. Maybe it gets disabled elsewhere, but if not, could that be the problem?

Comment 5

8 years ago
Oh. Ha. There are two bugs here: "removeAllCookies" doesn't disable on empty load or on clicking it, and "removeCookies" doesn't disable on load (but *does* after clicking "removeAllCookies").

Your patch fixes the first. (I think... does it fix the empty load case?)

Maybe it fixes the second because there's some logic to couple "removeAllCookies" to "removeCookies"? There must be somewhere, given the behavior.

Comment 6

8 years ago
Comment on attachment 434414 [details] [diff] [review]
Patch v0.1

Minusing based on comments.
Attachment #434414 - Flags: review?(dwitte) → review-
Paul, any update for this bug? I know it's not that important but it will fix one of our Mozmill tests so we can clearly test the ui bits.
No update. Probably won't happen in the 4.0 timeframe given it's low priority and the fact that we've already shipped with this bug before.
Assignee: paul → nobody
Status: ASSIGNED → NEW
You need to log in before you can comment on or make changes to this bug.