Bank of America SafePass does not work in Firefox 3.5, with an error in advanced Flash features

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
11 months ago

People

(Reporter: dweiss2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090803 Ubuntu/9.04 (jaunty) Shiretoko/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090803 Ubuntu/9.04 (jaunty) Shiretoko/3.5.2

When I try to log into my online banking with Bank of America and the feature "SafePass" I get an error message saying "Your internet browser does not support the advanced Flash features required to use SafePass.  Please upgrade your browser."  This feature works perfectly well in Firefox 3.0.  This has occured every time I have tried to use the online banking since upgrading to Firefox 3.5.

Reproducible: Always

Steps to Reproduce:
1. Go to https://www.bankofamerica.com
2. Attempt to log in using an account that has SafePass enabled.
Actual Results:  
I get the error message described above.

Expected Results:  
The feature is supposed to send a text message to my phone with a login code which I need to type in to log into the website.

I can provide a screenshot of what the error message looks like as well as what should actually happen (the correct feature will be from Firefox 3.0)

Comment 1

8 years ago
(Probably immaterial at this point, but ...)

Suspect that this is a UA (user agent) issue.
That BoA is looking for "Firefox", but the OP's UA string only contains "Shiretoko".

Try spoofing your UA, adding "Firefox/3.0" (or /3.5 or /3.6) to it.

Comment 2

11 months ago
Legacy extensions are no longer valid in Firefox 57, closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.