Firefox 3.5.2 freezes on Mac

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
9 years ago
9 years ago

People

(Reporter: anika.nui, Unassigned)

Tracking

({hang})

3.5 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

contrary to the user forum, 3.5.2 is STILL crashing a lot. Not a problem before 3.2.5. Happens on page loads of any site I go to regularly. Those sites are highly trafficked well build website. Launch of Flash is not the only thing that causes it. Just loading a page.  

Others are still reporting this on the forum, despite it being marked solved. The "solution" is actually a problem description, not a solution. 

2 times a day on average. Right away or after it has been running a while. Even after reboot. 

Thank you!


Reproducible: Sometimes

Steps to Reproduce:
Can't reproduce reliably. if i restart FF it will load the page.. 1.

Actual Results:  
1. force quit
2. reboot daily

still happens

Expected Results:  
works for a while

using default theme - what ever that is, never changed it. Right now, additional apps running at same time are stickies and MS Word. They are fine. I am not always running Word.
>contrary to the user forum, 3.5.2 is STILL crashing a lot
>UNSOLVED: Firefox 3.5.2 freezes

Do you gte a crash or a freeze ?
Did you already tried running Firefox in the Firefox safemode ?
http://support.mozilla.com/en-US/kb/Safe+Mode

Do you get the freeze on some pages or random ?
Do you use google mail or yahoo mail ?

BTW: You don't get solutions in bugzilla because it's a bug database for the developers.
Summary: UNSOLVED: Firefox 3.5.2 freezes → Firefox 3.5.2 freezes

Updated

9 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

9 years ago
Thank you!

Random (seems to be)

Google Mail

Firefox "Not Responding" No error report. 

    and sometimes

just poof and its gone. NO error report.

Will try Safe Mode tonite and tomorrow and let you know.

Thankyou
Summary: Firefox 3.5.2 freezes → Firefox STILL 3.5.2 freezes on Mac
Whiteboard: Somehow the title changed, it originally said "on Mac" and Forum Issue not solved, as site indicates.
if safe mode does not work, please create a new profile as well. This only happens when you go to Gmail?
Summary: Firefox STILL 3.5.2 freezes on Mac → Firefox 3.5.2 freezes on Mac
Whiteboard: Somehow the title changed, it originally said "on Mac" and Forum Issue not solved, as site indicates.
(Reporter)

Comment 4

9 years ago
not just gmail, also huff po AND others. I know clicking a link that goes to another site can lead to hard landings. but that is not the only thing. Let me try safe mode a couple days. i was viewing "Ponyo" today and off my mac. 
really appreciate your assistance.
(Reporter)

Comment 5

9 years ago
Just happened. This time got chance to do a bug report for, what it's worth.

Went to http://veganacious.com/shop.

linked to there from veganacious.com.I was able to revisit the page (veganacious.com/shop.)

FF is the only thing running at the time, no other apps open. 

Not all the tabs I had re-opened, but Gmail did as well as Google Docs.

I cannot figure out what "Change profile" means. In Google Mail? In Firefox? I can't think of any Mac profile. I don't use Apple Mail.

I just now changed in Gmail to use "older version" but that is still just 3.5.2.

So, unless you can explain about change profile, I can't figure what next.

I appreciate the help very much.

Add-ons: gmail_sigs@blankcanvasweb.com:1.11.12,{000a9d1c-beef-4f90-9363-039d445309b8}:0.5.30.0,{972ce4c6-7e08-4474-a285-3208198ce6fd}:3.5.2
BuildID: 20090729211433
Comments: on a website called http://veganacious.com/shop.

have a bug report open
CrashTime: 1251932913
InstallTime: 1250821907
ProductName: Firefox
SecondsSinceLastCrash: 413277
StartupTime: 1251865305
Theme: classic/1.0
Throttleable: 1
Vendor: Mozilla
Version: 3.5.2
(Reporter)

Comment 6

9 years ago
OH, and the veganacious.com/shop page came up, too.
Can you please create a new firefox profile. http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 8

9 years ago
Went to http://support.mozilla.com/en-US/kb/Managing+profiles.

Looked at that page and one or two others related in knowledge base.

Watched movie.

Quit FF.

Opened Terminal. ......Terminal bash 80x24 window opened. tried changing the txt. Fortunately it does not save because i accidentally added something. (Hitting enter key re-enters first line. "Last login: Sat Apr 18 10:25:18 on console
Anika-Glasss-MacBookAir:~ anikaglass$". If I add the line in the terminal window, it does not save on exit. 

I have no recollection of opening Console in April of any year.

No "save" drop down I can find. "Undo" is grayed out. No able to create a new window or write a new file. if i try to do this, the same window opens up and I can't save changes to it, either. 

        there seems to be something missing here after hitting 'return' and
        then restarting FF. ??

Searched COMPUTER for "/Applications/Firefox.app/Contents/MacOS/firefox -ProfileManager" and I don't have one. looked everywhere for ProfileM and not on my computer in any folder anywhere.

Searched computer for "~/Library/Application Support/Firefox/Profiles/xxxxxxxx.default/".  My xxxxxxxx.default is a FOLDER with a lot of things in it. The instructions say 

  " 1.  Open Finder and go to your home folder. Note: your home folder is
         usually the name of your Mac user account
   2. From your home folder open /Library/, then /Application Support/,
       then /Firefox/, then /Profiles/.
   3. Open your profile folder. By default, it is /xxxxxxxx.default/
      where xxxxxxxx represents a random string of 8 characters."

THERE IS NO STEP 4. SHOULD I DELETE THE WHOLE FOLDER? MOVE it? Click one of the things in it. If so, then what. I mean I found it but what am i supposed to do with it. 

Restarted FF. Don't see anything in FIREFOX pull downs nor Preferences to open the Profile Manager or the Wizard. 

Can't find anything called Wizard on my computer.

At some point along all this my Console app also opened but it is closed right now.

Nothing has been changed on my computer of FF settings since i started the described adventure.

Other notes: 1. The connection between fussing in Terminal application and starting the Wizard is or Profile Manager is unclear to me. 2. if I got into the Profile manager would I add a profile and delete the default? that sounded like not a good idea.
so pasting "/Applications/Firefox.app/Contents/MacOS/firefox -ProfileManager" (without the quotation marks) and pressing enter does not help? If you get to the profilemanager, you will simply add a new one, open Firefox in it, and then try to reproduce the hang. You should not delete your old one. I believe that you can take your xxxxxxx.default folder and move it away, just make sure you do not leave it there. I believe that Firefox will recreate the profile (I am not sure on mac).
(Reporter)

Comment 10

9 years ago
something is starting to work. repeated some steps. hang on.
(Reporter)

Comment 11

9 years ago
I got the Firefox - Choose User Profile to open! Now I did that with FF running. So I created a new profile. I Then clicked Start Firefox even though it was already running. (believe it or not, two FF apps are running at same time. Going to quit out both THEN restart FF and see what happens.
You don't need to post replies in real time :)
I don't think it should be coming up with another firefox process. That is kinda odd. Let me know if a new profile does work though. It will not have bookmarks besides the default ones.
(Reporter)

Comment 13

9 years ago
well, it WAS odd. Macs don't do that.But it did, i updated this page with my comment and quit it saving tabs. I quit the other same app not saving tabs.(it was just the Mozilla landing page.)

I restarted FF and of course, the one that came up was the Mozilla landing page. So I have a new profile. 

With NO bookmarks. NO bookmark tool bar. No cookies. (not a problem) and No nuthin' Man that is frustrating.

But if it works, maybe I'll try to figure out how to start the old default profile if I need to remember some. Or find them somewhere on my computer. or something.

Hopefully this works!

You da bomb, as we say here. Real time is good as where I am it is 3:35 the PM on Sept 2. Where you are is probably like 10:35 or something. 

can we keep this "Unsolved" for a few days till I am sure I am not still crashing, please. I hate starting over.
well, yeah, with a new profile you will have nothing. that is the point, as it is to make sure that there is no profile corruption, extension issues, etc. Your old profile is still there, just open up the profile manager, and select the old profile, and there is all your old stuff. You can use support to help you figure out how to move your old stuff over to the new one. http://www.mozilla.com/en-US/.

Well, it is actually around 7:50PM here, but glad you were able to get this going. I will leave the bug as UNCO, but please report back as soon as you get more info (if it happens or not) so then we can close it. Even if we do close it, you can always reopen it.
(Reporter)

Comment 15

9 years ago
Mahalo
(Reporter)

Comment 16

9 years ago
And after appending that line to the one that auto opened in Terminal, I just quit terminal. Restarted FF okay. Upon reopen of Terminal the appended line is not there. 

Now that is something that could be added to the knowledge base.
He mea iki :)
Well, you could probably talk to the support people and they can check that.
(Reporter)

Comment 18

9 years ago
Everything is working fine.

I had carefully marked bookmarks for genealogy research. I may have to go back and get those. 

These steps worked. The documentation/knowledge base is lacking in clarity about how to do it.
Keywords: crash
(Reporter)

Comment 19

9 years ago
Comments 8 and 16 describe what i did after all the help from Tyler. His instructions are very helpful.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
marking wfm because fixed is only used with a patch
Resolution: FIXED → WORKSFORME
glad it is gone. hang, not a crash.
Status: RESOLVED → VERIFIED
Keywords: crash → hang
(Reporter)

Comment 22

9 years ago
i'm going to try to use this guidance back up and remove the settings file for FF before I take my mac in for repair tomorrow. It's one third the key to not turning it over without my 1. bookmarked websites leading to 2. accounts names to 3. prompted password. which seems like a wise thing to do . ther'll still be stuff on it, but after I clear out all settings in the OS and FF I should keepp all but a rookie out. I hope.
You need to log in before you can comment on or make changes to this bug.