Closed Bug 513929 Opened 14 years ago Closed 14 years ago

tinderbox log highlighter should highlight when build steps fail

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 522792

People

(Reporter: dbaron, Unassigned)

Details

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251811567.1251821470.14716.gz
is an example log of when the tinderbox log highlighter doesn't highlight the failure that caused the build to be red.

In this case, the minimal error is:

'make buildsymbols' failed

I think highlighting on "' failed$" might actually give us reasonably useful information.  ($ being end-of-line)

It also probably should have highlighted:

command timed out: 1200 seconds without output

which I thought it usually does, but didn't in this case.
Component: Release Engineering → Release Engineering: Future
Also, for many out-of-disk-space errors, this would help:

/finished with exit code [1-9]/
Probably want [^0] there because we get exit codes like 255 for crashes.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Moving closed Future bugs into Release Engineering in preparation for removing the Future component.
Component: Release Engineering: Future → Release Engineering
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.