Search: App version filter not being honored

VERIFIED FIXED in 5.2

Status

--
blocker
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: davedash, Assigned: davedash)

Tracking

unspecified
Dependency tree / graph

Details

Attachments

(2 attachments)

If I search for ebay for extensions that work with FF 3.5, I get extensions that don't work.

This has to do with how we determine that max/min supported ver for an addon.
(In reply to comment #0)
> If I search for ebay for extensions that work with FF 3.5, I get extensions
> that don't work.
> 
> This has to do with how we determine that max/min supported ver for an addon.

Current code, or the code you're rewriting?
The new sphinx-based code...
awesomepants:~/Projects/Addons/code % gitbz.pl Updated view to show correct max/min versions                                                                                               (513965-search-version)
git commit -m "[bug 513965] Updated view to show correct max/min versions"
[513965-search-version e783c3d] [bug 513965] Updated view to show correct max/min versions
 2 files changed, 4 insertions(+), 4 deletions(-)
awesomepants:~/Projects/Addons/code % git svn dcommit                                                                                                                                      (513965-search-version)
Committing to https://svn.mozilla.org/addons/trunk ...
        M       site/cake/libs/configure.php
Committed r50605
        M       site/app/locale/sr/LC_MESSAGES/messages.po
r50602 = b31951f0eaf012d973527e00043bcb6e83d65a14 (trunk)
        M       site/cake/libs/configure.php
r50605 = d74439b2314b00415153652fe39b686e158f0d2b (trunk)
W: 4c73543ac7cf466a0eb9edbe21454471c7f99127 and refs/remotes/trunk differ, using rebase:
:040000 040000 7e2dd53946bf395bee1d3a5f89e02ac12ed59134 d7f448d0377b5fa70d298c167e4263fc2133c941 M      site
First, rewinding head to replay your work on top of it...
Applying: [bug 513965] Updated view to show correct max/min versions
        M       site/app/config/sql/remora.sql
        M       site/app/config/sql/sphinx.sql
Committed r50606
        M       site/app/config/sql/remora.sql
        M       site/app/config/sql/sphinx.sql
r50606 = bf49c2607e6db1f38b65afbdb1c01847890ae257 (trunk)
No changes between current HEAD and refs/remotes/trunk
Resetting to the latest refs/remotes/trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
I can reproduce this on Linux.
Assignee: dd → bmo
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

10 years ago
OS: Mac OS X → All
Hardware: x86 → All

Updated

10 years ago
Assignee: bmo → dd
Milos-

I'm missing the point of your video.  Which of the results didn't belong?

-d
Target Milestone: 5.1 → 5.2
We're having some cross over with applications too.  

https://services.addons.mozilla.org/en-US/mobile/api/1.2/search/twitter/all/10/Linux/1.0b4

is asking for stuff compatible with 1.0b4 of fennec apps but returns nothing.  Apparently the version at the end is only affecting firefox apps, as changing it to 3.0 gives us results.

This is blocking fennec.
(In reply to comment #6)
> This is blocking fennec.

We need this fixed asap and we'll have to do an off-cycle push.  ->blocker
Severity: normal → blocker
https://litmus.mozilla.org/show_test.cgi?id=9552 has just a couple testcases that I cobbled together from #amo today -- please feel free to augment directly or add additional cases here, and I'll add them to the testcase.
So the current status is this.  The view that holds the search index was
somewhat overloaded when I tried to get this to work (took 15 mins to index).

My new approach is to write an actual table, with the fields I want, that will
be populated by a script.  If the script runs fast enough, I'll just run that
every time we index.  If it takes a bit of time, I'll look into triggers, or
updating this index on the application side after certain events.

I'll be working on this all day today, and should have something committed, I'll have to help IT with installing this.
Posted patch v1Splinter Review
This patch includes:

* a shell script which IT can edit to their liking, that calls an index script and the sphinx indexer
* a python script which (re)builds an database table which sphinx can feed off of

It's intended that the database table will be created on the same host (preferably an unreplicated slave) that sphinx will read from - as this does not need to be replicated to other mysql nodes.

After review of this patch, I will file a blocking IT bug to launch this onto preview so QA can have at it.

After QA approves this, I will file another bug to push this into production sometime on Monday.

-d
Attachment #404354 - Flags: review?(clouserw)
Oh, I'll of course update the instructions here:

https://intranet.mozilla.org/WebSites#Sphinx
Comment on attachment 404354 [details] [diff] [review]
v1

If you think it's the way to go lets get it landed so we can start testing
Attachment #404354 - Flags: review?(clouserw) → review+
Duplicate of this bug: 517587
Fixed
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 520270

Comment 16

10 years ago
Search looks broken in preview

STR:
Search for "firebug"



https://preview.addons.mozilla.org/en-US/firefox/search?q=firebug&cat=all

reopening...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

10 years ago
Depends on: 520516

Comment 17

10 years ago
I have filed Bug 520516 for the issue reported in comment#16.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Verified FIXED; the Mobile team says it's good, and I've re-run the tests in prod; all's well.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Blocks: 540816
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.