awesomebar sizing is broken on maemo

VERIFIED FIXED in fennec1.0b4

Status

Fennec Graveyard
General
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: Gavin, Assigned: mfinkle)

Tracking

Trunk
fennec1.0b4
ARM
Maemo

Details

Attachments

(1 attachment)

Bug 513723 made us use availWidth, which is always 720 on the n810, even when we're in fullscreen mode.

This means the popup is too small when in fullscreen mode (the default).

Not sure what the best way to fix this is - you could argue that the gtk window code should ignore the OS "sidebar" when determining availWidth in fullscreen. Not sure if it can tell whether it's in "full screen mode", though.
Created attachment 397965 [details] [diff] [review]
patch

We probably don't need this screen.availXxx check in the resize handler.Certainly won't break Maemo. Should not break WinMo.
Assignee: nobody → mark.finkle
Attachment #397965 - Flags: review?(gavin.sharp)
Attachment #397965 - Flags: review?(gavin.sharp) → review+
pushed: https://hg.mozilla.org/mobile-browser/rev/2e8e83aac0d0
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Target Milestone: --- → B4
verified on my n810 with 20090921 1.9.2 nightly build
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Linux/Maemo → General
OS: All → Linux (embedded)
QA Contact: maemo-linux → general
Hardware: All → ARM
Duplicate of this bug: 514203
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.