Closed Bug 513999 Opened 10 years ago Closed 10 years ago

mochitest-plain hanging during shutdown

Categories

(Core :: General, defect, P1, blocker)

x86
Linux
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: cpearce)

References

Details

(Keywords: intermittent-failure)

Starting at 2009/08/30 19:12:43 the mochitest-plain suite is exhibiting a new kind of "random" failure: the suite is completing, but during shutdown the browser apparently hangs, or at least stops responding for 300 seconds.

This has happened for at least 50% of the Linux unittest builds since then, and some of the separate-Mochitest builds.

I'm going to tentatively blame bug 512328 (upgrade liboggplay), because this seems to have started with http://hg.mozilla.org/mozilla-central/rev/fb6d235b9efb and that patch has some fun changes in terms of which functions are called holding locks, etc.

It's possible that some of the immediately prior landings triggered this instead: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=aa3a30f3f1e8&tochange=fb6d235b9efb

Unless you have better options, I'd like the liboggplay changes backed out for a day to see if that makes the hang/orange go away.
Severity: normal → blocker
OS: Windows NT → Linux
Priority: -- → P1
Whiteboard: [orange]
Isn't this just bug 503623?
No. In that case the test may hang, but it will not hang after all the tests appear to have completed (on shutdown).
Due dilligence:

Linux mozilla-central unit test on 2009/09/01 12:55:56
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251834956.1251842516.27964.gz

Linux mozilla-central unit test on 2009/09/01 12:03:16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251831796.1251839570.28029.gz

Linux mozilla-central unit test on 2009/09/01 09:50:30
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251823830.1251831956.9021.gz

Linux mozilla-central unit test on 2009/09/01 09:44:09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251823449.1251831213.424.gz

Linux mozilla-central unit test on 2009/09/01 08:15:21
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251818121.1251826303.8091.gz

Linux mozilla-central unit test on 2009/09/01 08:15:21
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251818121.1251826303.8091.gz

Linux mozilla-central unit test on 2009/08/31 09:35:39
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251736539.1251747606.591.gz

Linux mozilla-central unit test on 2009/08/30 19:12:43
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251684763.1251695339.25850.gz

Linux mozilla-central unit test on 2009/08/30 19:12:43
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251684763.1251695339.25850.gz

Checkin:
Sun Aug 30 19:09:40 2009 -0700	fb6d235b9efb	Chris Pearce — Bug 512398 - fix liboggplay update (rev f4087c5ac148) which accidentally removed liboggplay's os2_semaphore.*. r=doublec
Blocks: 499512
Blocks: 506305
Blocks: 507167
Closing bug. No more occurrences since the backout. Looks like it's caused by the audio hardware clock not advancing in nsOggDecodeStateMachine::PlayFrame(). That explains why it only occurs under linux too.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
No longer blocks: 506305
No longer blocks: 499512
Blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.