Last Comment Bug 514131 - Kill xpcom/obsolete
: Kill xpcom/obsolete
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9.3a1
Assigned To: Mitchell Field [:Mitch]
:
Mentors:
: 282808 (view as bug list)
Depends on: 38122
Blocks: 513924 540470
  Show dependency treegraph
 
Reported: 2009-09-01 23:29 PDT by Mitchell Field [:Mitch]
Modified: 2010-02-17 17:55 PST (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1.0 (430.46 KB, patch)
2009-09-01 23:29 PDT, Mitchell Field [:Mitch]
no flags Details | Diff | Review
Patch v1.1 (430.49 KB, patch)
2009-09-02 00:06 PDT, Mitchell Field [:Mitch]
benjamin: review+
Details | Diff | Review
Bundle v1.1 (2.94 KB, application/octet-stream)
2009-09-02 07:06 PDT, Mitchell Field [:Mitch]
no flags Details

Description Mitchell Field [:Mitch] 2009-09-01 23:29:19 PDT
Created attachment 398088 [details] [diff] [review]
Patch v1.0

It's obsolete and should go away.
This patch is an attempt to make it go away.
Comment 1 Mitchell Field [:Mitch] 2009-09-02 00:06:17 PDT
Created attachment 398089 [details] [diff] [review]
Patch v1.1

This actually builds.
Comment 2 Mitchell Field [:Mitch] 2009-09-02 07:06:36 PDT
Created attachment 398122 [details]
Bundle v1.1

This is a bundle of the previous changes.
Comment 3 Benjamin Smedberg [:bsmedberg] 2009-09-02 07:51:46 PDT
Comment on attachment 398089 [details] [diff] [review]
Patch v1.1

Awesome.

Please file a followup bug about removing the nsIPref API which is no longer supported (Get/SetFilePref)
Comment 4 Benjamin Smedberg [:bsmedberg] 2009-09-02 11:24:18 PDT
http://hg.mozilla.org/mozilla-central/rev/d578481cbc37
Comment 5 Makoto Kato [:m_kato] (PTO 6/20-21, 6/24) 2009-09-02 20:15:31 PDT
*** Bug 282808 has been marked as a duplicate of this bug. ***
Comment 6 Makoto Kato [:m_kato] (PTO 6/20-21, 6/24) 2009-09-02 20:19:57 PDT
(In reply to comment #3)
> (From update of attachment 398089 [details] [diff] [review])
> Awesome.
> 
> Please file a followup bug about removing the nsIPref API which is no longer
> supported (Get/SetFilePref)

It is filed as bug 214796.
Comment 7 Serge Gautherie (:sgautherie) 2010-02-17 17:55:54 PST
Comment on attachment 398089 [details] [diff] [review]
Patch v1.1

>diff --git a/configure.in b/configure.in
>-if test -n "$MOZ_NO_XPCOM_OBSOLETE" && test `echo "$MOZ_EXTENSIONS" | grep -c sroaming` -ne 0; then
>-    AC_MSG_WARN([Cannot currently build sroaming without xpcom obsolete -- bug 249343. Removing sroaming from MOZ_EXTENSIONS.])
>-    MOZ_EXTENSIONS=`echo $MOZ_EXTENSIONS | sed -e 's|sroaming||'`
>-fi

Bug 249343 is not fixed. Why remove this code?

Note You need to log in before you can comment on or make changes to this bug.