Last Comment Bug 514198 - freetype2 (cairo) doesn't compile on m-1.9.1
: freetype2 (cairo) doesn't compile on m-1.9.1
Status: VERIFIED FIXED
[fixed by bug 609114]
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 1.9.1 Branch
: x86 Windows 2000
: -- normal (vote)
: mozilla2.0b8
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
:
Mentors:
Depends on: 609114
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-02 08:43 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-01-16 18:17 PST (History)
4 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Serge Gautherie (:sgautherie) 2009-09-02 08:43:00 PDT
m-c:
make -B -C objdir/modules/freetype2
builds fine.


m-1.9.1:
make -B -C objdir/gfx/cairo/cairo/src
{
cairo-ft-font.c
\gfx\cairo\cairo\src\cairo-platform.h(53) : warning C4005: 'cairo_public' : macro redefinition
        \gfx\cairo\cairo\src\cairoint.h(54) : see previous definition of 'cairo_public'
\gfx\cairo\cairo\src\cairo-ft.h(49) : fatal error C1083: Cannot open include file: 'ft2build.h': No such file or directory
make[1]: *** [cairo-ft-font.obj] Error 2
make[1]: Leaving directory `objdir/gfx/cairo/cairo/src'
}

I initially tried on ThunderbirdTry:
{
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1251848210.1251859669.21738.gz&fulltext=1

d:\buildbot\sendchange-win32-hg\mozilla\mozilla\gfx\cairo\cairo\src\cairo-ft.h(49) : fatal error C1083: Cannot open include file: 'ft2build.h': No such file or directory
}
(and I filed bug 514058 too...)

***

At first glance, it would look like, m-1.9.1 either:
should not have "Bug 462908 - Implement Freetype font backend for windows ce" or should be disabled for windows desktop or something,
or is missing "Bug 463532 - import freetype into the tree".
Comment 1 Peter Weilbacher 2009-09-06 04:42:53 PDT
What's your configuration? I don't think cairo should be configured to enable the FreeType backend by default on Windows. Do you have the FreeType _library_ installed on your machine but are missing the developer portion (the headers)?
Comment 2 Serge Gautherie (:sgautherie) 2009-09-06 08:37:15 PDT
I noticed m-1.9.1 misses
http://mxr.mozilla.org/mozilla1.9.2/source/modules/freetype2/
though --enable-tree-freetype is available.
I tried the latter because I wanted to try and clean it up in c-c.

As I see it, m-1.9.1 is
*either missing the in-tree freetype2,
*or missing some configure check to detect there is no external library available
 (unless it should not even have that option?).
Comment 3 JP Rosevear [:jpr] 2012-01-06 14:46:17 PST
As part of bug 609114 we block freetype2 in tree builds for MSVC
Comment 4 Serge Gautherie (:sgautherie) 2012-01-16 18:17:44 PST
m-1.9.1 is long dead.

Trying to build Firefox 12a1 with '--enable-tree-freetype' and VC8EE returns:
{
configure: error: building with in-tree freetype is not supported on MSVC
}
as now expected.

V.Fixed

Note You need to log in before you can comment on or make changes to this bug.