Sometimes Acid3 test 80 fails

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: Alexandros T, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090803 Ubuntu/9.04 (jaunty) Shiretoko/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090803 Ubuntu/9.04 (jaunty) Shiretoko/3.5.2

I tried the Acid3 test with Firefox 3.5.2 in Ubuntu Jaunty and sometimes test 80 fails.

Reproducible: Sometimes

Steps to Reproduce:
1.Go to acid3.acidtests.org
2.while (score!=93) refresh page
Actual Results:  
Firefox 3.5.2 most of the times scores 93, but sometimes it scores 92 (with test 80 failing)

Expected Results:  
Test 80 should either always pass or always fail.

Failed 8 tests.
Test 04 passed, but took 34ms (less than 30fps)
Test 26 passed, but took 485ms (less than 30fps)
Test 40 passed, but took 40ms (less than 30fps)
Test 71 failed: doc.open is not a function
Test 72 failed: doc.images is undefined
Test 75 failed: anim.beginElement is not a function
Test 76 failed: expected '0' but got '100' - Incorrect animVal value after svg animation.
Test 77 failed: expected '4776' but got '7180' - getComputedTextLength failed.
Test 78 failed: expected '90' but got '0' - getRotationOfChar(0) failed.
Test 79 failed: expected '34' but got '33' - SVGSVGTextElement.getNumberOfChars() incorrect
Test 80 failed: kungFuDeathGrip was null
Total elapsed time: 2.64s

Comment 1

7 years ago
This was a bug with the Acid test - resolved at their end.

Comment 2

7 years ago
There's also a webkit bug: https://bugs.webkit.org/show_bug.cgi?id=18144

In any case, please test with the latest version (currently Firefox 4 beta), if an issue like this is 3.5-specific, there's little chance it will be fixed.

Danny, do you have a reference link?

Comment 3

7 years ago
Acid3 source code, Line 3111 - and a relevant forum post - which outlined the chronology of this change - which I've got basically no chance of finding again :(

Comment 4

7 years ago
Ah, I thought this bug was filed in september this year, so was looking for a recent fix to the test. Thanks!

http://ln.hixie.ch/?start=1270240159&count=1

      // test 80: remove the iframes and the object
      // (when fixing the test for http://dbaron.org/mozilla/visited-privacy,
      // this section was flipped around so the linktest check is done first;
      // this is to prevent the 'retry' from failing the second time since by
      // then the kungFuDeathGrip has been nullified, if we do it first)
      // first, check that the linktest is loaded
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.