If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

test_focus.xul makes incorrect assumptions about getElementById

RESOLVED FIXED

Status

()

Core
DOM
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: bz, Assigned: Neil Deakin)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

Attachments

(1 attachment)

I had to disable dom/tests/mochitest/chrome/test_focus.xul, because it was relying on a bug in getElementById.  It's not clear to me offhand how this test _should_ work, exactly...

The bug it was relying on was returning XBL anonymous nodes from getElementById.  Maybe we should be passing around nodes, not ids, more?
(Assignee)

Comment 1

8 years ago
(In reply to comment #0)
> I had to disable dom/tests/mochitest/chrome/test_focus.xul, because it was
> relying on a bug in getElementById.  It's not clear to me offhand how this test
> _should_ work, exactly...

Can you disable just the part that does this? This part is from the comment 'tests to check if tabbing out of a textbox works' to the last call to expectFocusShift.

http://mxr.mozilla.org/mozilla-central/source/dom/tests/mochitest/chrome/window_focus.xul#736

I think there was some reason why ids were used instead of elements, but don't recall what it was. I'll investigate or just create some other mechanism for this part of the test.
> Can you disable just the part that does this?

I can do that if I don't figure out a quick way to make this work otherwise.  Looking at it now.
(Assignee)

Comment 3

8 years ago
Created attachment 398720 [details] [diff] [review]
change to use elements rather than ids

Also fixes a problem caused by bug 504533 on Mac with the Full Keyboard Access setting is 'all' (not the default on test machines) because tabs are now focusable.
Attachment #398720 - Flags: review?(Olli.Pettay)

Comment 4

8 years ago
(In reply to comment #3)
> Also fixes a problem caused by bug 504533
Wrong bug number?
(Assignee)

Comment 5

8 years ago
Sorry, I meant 491636.

Updated

8 years ago
Attachment #398720 - Flags: review?(Olli.Pettay) → review+
(Assignee)

Comment 6

8 years ago
http://hg.mozilla.org/mozilla-central/rev/fc5cc68df731
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
I pushed a merge of this to 1.9.2 branch as http://hg.mozilla.org/releases/mozilla-1.9.2/rev/9c6a2eb24042 because otherwise the fix for bug 489925 was making it orange...  I hope I got the merging right.  ;)
status1.9.2: --- → beta1-fixed
You need to log in before you can comment on or make changes to this bug.