Upgrading Minefield while minimized makes it impossible to open the window afterwords.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1) Gecko/20090806 Namoroka/3.6a1
Build Identifier: Minefield - Sept 1/2, 2009

I checked for updates to Minefield by going to Help -- Check for Updates.
It said that there was an update, so I began downloading the update. Sometime before I clicked the button to restart Minefield to apply the update, I minimized my browser's main window. I then clicked the button, and it prompted me for UAC authorization, which I granted. From then on, I have been unable to un-minimize that browser window. It shows my Minefield shortcut in the taskbar as open, but I can't restore/maximize the window. 

I can close that process and it will happen again the next time I try to open it, regardless of whether I use the Taskbar shortcut or the shortcut in the start menu.

Reproducible: Always

Steps to Reproduce:
1. Download a nightly update to Minefield.
2. Minimize the main browser window.
3. Click the button to apply/install the new update.
4. Let the update proceed.
5. Be unable to use Firefox.
Actual Results:  
The update applies itself successfully, but the browser resumes in a minimized state, and it is unable to change from that state.

Expected Results:  
Having it start up minimized is alright, but I expect it to be able to restore itself to a visible window when I click on it.

My shortcut has it start up Minefield with a non-default profile, with the "-no-remote" flag set. (Although I can't get it to start unminimized when I use a regular shortcut either.)

Firefox is set to resume my previous session when it restarts, if that matters.

Closing Firefox and then selecting one of the "Recent" links from the shortcut's jumplist did open a non-minimized window (although the window was shrunk down to barely fit the default titlebar elements). I've then been able to open Minefield with the normal shortcut after I did this.
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
Can't reproduce this anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.