nsinstall error "nssutil3.pdb: No such file or directory" when building WINCE with MOZ_DEBUG_SYMBOLS set

RESOLVED FIXED

Status

NSS
Build
P2
normal
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: nthomas, Assigned: blassey)

Tracking

3.12.4
ARM
Windows CE

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
nsinstall -m 664 /e/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/nss/nssutil/nssutil.lib e:/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/dist/lib
nsinstall -m 775 /e/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/nss/nssutil/nssutil3.dll e:/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/dist/lib
nsinstall -m 644 /e/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/nss/nssutil/nssutil3.pdb e:/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/dist/lib
nsinstall: e:\builds\moz2_slave\mozilla-central-wince-nightly\build\obj-firefox\nss\nssutil\nssutil3.pdb: No such file or directory

Example log, a clobber:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251885720.1251890078.25778.gz
That's for a mozilla-central build using NSS 3.12.4.
(Reporter)

Updated

8 years ago
Hardware: x86 → ARM

Comment 1

8 years ago
Nick, none of the NSS developers do WINCE builds, so one
of the Fennec developers will need to look into this and
submit a patch.

Could you get a directory listing of the
e:\builds\moz2_slave\mozilla-central-wince-nightly\build\obj-firefox\nss\nssutil
directory?  Is there any .pdb file there?
(Reporter)

Comment 2

8 years ago
Doesn't appear to be:

cltbld@WIN32-SLAVE18 /e/builds/moz2_slave/mozilla-central-wince/build/obj-firefox/nss/nssutil
$ ls
derdec.obj   nssilock.obj  nssutil3.exp   secalgid.obj  secitem.obj
derenc.obj   nssrwlk.obj   nssutil3.lib   secasn1d.obj  secoid.obj
dersubr.obj  nssutil.def   nssutil3.map   secasn1e.obj  secport.obj
dertime.obj  nssutil.lib   oidstring.obj  secasn1u.obj  sectime.obj
nssb64d.obj  nssutil.res   portreg.obj    secdig.obj    templates.obj
nssb64e.obj  nssutil3.dll  quickder.obj   secinit.obj   utf8.obj

Comment 3

8 years ago
This is the important part of the build log, where we built
nssutil3.dll.  Does this generate a nssutil3.pdb file?

/e/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/dist/sdk/bin/arm-wince-link -DLL -OUT:"/e/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/nss/nssutil/nssutil3.dll" -DEF:/e/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/nss/nssutil/nssutil.def -MAP  \\e\\builds\\moz2_slave\\mozilla-central-wince-nightly\\build\\obj-firefox\\nss\\nssutil\\quickder.obj [...other .obj files omitted...] \\e\\builds\\moz2_slave\\mozilla-central-wince-nightly\\build\\obj-firefox\\nss\\nssutil\\utf8.obj   e:\\builds\\moz2_slave\\mozilla-central-wince-nightly\\build\\obj-firefox\\dist\\lib\\plc4.lib e:\\builds\\moz2_slave\\mozilla-central-wince-nightly\\build\\obj-firefox\\dist\\lib\\plds4.lib e:\\builds\\moz2_slave\\mozilla-central-wince-nightly\\build\\obj-firefox\\dist\\lib\\nspr4.lib    \\e\\builds\\moz2_slave\\mozilla-central-wince-nightly\\build\\obj-firefox\\nss\\nssutil\\nssutil.res
Microsoft (R) Incremental Linker Version 9.00.21022.08
Copyright (C) Microsoft Corporation.  All rights reserved.

   Creating library e:/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/nss/nssutil/nssutil3.lib and object e:/builds/moz2_slave/mozilla-central-wince-nightly/build/obj-firefox/nss/nssutil/nssutil3.exp
That won't; needs a -PDB:"..../nssutil3.pdb", otherwise it'll (I think) be named something generic.  But there's also no -DEBUG there to begin with...

Comment 5

8 years ago
I think you need to study how you cross-compile NSS for WINCE
in http://mxr.mozilla.org/mozilla-central/source/security/manager/Makefile.in#241

You may need to pass additional linker or compiler flags to
NSS when MOZ_DEBUG_SYMBOLS is defined.  Alternatively, as a
workaround, don't export MOZ_DEBUG_SYMBOLS for NSS when you
are cross-compiling NSS for WINCE.

If MOZ_DEBUG_SYMBOLS is defined, NSS expects a .pdb file.
I don't see anything obviously wrong with those make arguments, but it's possible that our entire WinCE build doesn't handle MOZ_DEBUG_SYMBOLS properly.
Created attachment 399252 [details] [diff] [review]
doesn't export MOZ_DEBUG_SYMBOLS for WINCE

It would be nice to fix nss to produce symbols, but until that happens let's not have a broken build
Assignee: nobody → bugmail
Attachment #399252 - Flags: review?(ted.mielczarek)

Comment 8

8 years ago
Comment on attachment 399252 [details] [diff] [review]
doesn't export MOZ_DEBUG_SYMBOLS for WINCE

Brad, this workaround is fine.  Please add a comment to
explain why (at least reference this bug).
Attachment #399252 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 399252 [details] [diff] [review]
doesn't export MOZ_DEBUG_SYMBOLS for WINCE

This is fine, but please leave this bug open for a real fix.
wince workaround - http://hg.mozilla.org/mozilla-central/rev/29c386b16010
wtc, i missed your request to add a comment, sorry.  Maybe blassey or I can investigate the actual bustage in the very near term allowing us to back out that workaround.

Comment 12

8 years ago
dougt: just add a "See bug 514295" comment!
http://hg.mozilla.org/mozilla-central/rev/bac4068e7adb <- comment
(Assignee)

Updated

8 years ago
Duplicate of this bug: 515641
(Assignee)

Updated

8 years ago
Flags: blocking1.9.2?
(Assignee)

Updated

8 years ago
Attachment #399252 - Flags: approval1.9.2?
Flags: blocking1.9.2? → blocking1.9.2+

Updated

8 years ago
Attachment #399252 - Flags: approval1.9.2? → approval1.9.2+
pushed http://hg.mozilla.org/releases/mozilla-1.9.2/rev/32a459118bdf
status1.9.2: --- → beta1-fixed
Marking as P2.
Priority: -- → P2
A workaround was landed on trunk and 1.9.2 to avoid this, I don't think we need to block on the correct solution.
Removing blocking flag per Comment 17.
Flags: blocking1.9.2+
the workaround landed
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.