Closed Bug 514386 Opened 13 years ago Closed 12 years ago

Downloading too many messages over IMAP

Categories

(MailNews Core :: Networking: IMAP, defect)

1.9.1 Branch
x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 517466

People

(Reporter: Gijs, Unassigned)

Details

(Keywords: regression, Whiteboard: [has protocol logs])

Attachments

(1 file)

Attached image Statusbar screenshot
Every now and again, Thunderbird seems to be very happy to download random numbers of messages. It will then claim to be downloading eg. "message 9 of 3 in All Mail". This does not seem right (obviously!). I'm not really sure what causes it, from time to time things seem all fine and dandy, and sometimes this happens. The number of total / downloaded messages varies, the progress bar acts pretty randomly, too.

System details:
Mac OS X 10.4.11
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

Three IMAP accounts are set up. Two are using GMail, one is using my university's IMAP setup (exchange, sadly). I've only seen the problem with (one of? can't tell!) the two gmail accounts.

The profile used to be in use for TB 2, but I upgraded a while ago because TB2 kept 'losing' all the local mail when I switched time zones, which I do rather a lot (traveling between the UK and the Netherlands) and therefore found extremely annoying.

I apologize for the not-so-clear steps to reproduce, and would be more than happy to answer followup questions. Left this in General as I have no idea where it belongs at this point...
Anything in the activity manager , or in the Error console ?
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Version: 3.0 → 1.9.1 Branch
No related errors in the error console (warning about using a type=timed textbox, CSS issues).

In the activity manager, I have a lot of notifications "<account name> is now up-to-date (downloaded messages: N)", where N seems to correspond to the highest I've seen for these 'weird' "Downloading N of M" messages. Above those notifications, there are a bunch of errors:

"The current command did not succeed. The mail server responded:System error (Failure)"

The timestamps for these errors /seem/ unrelated to the success messages, so I am not sure what, if anything, they have to do with the actual issue I'm seeing...

Is there anything I could turn on to get more logging going? I can definitely keep an eye on the activity manager to see if I spot anything else that *is* "odd" (clearing it regular, and seeing what new messages pop up for these odd statusbar updates).
You could turn on imap login (https://wiki.mozilla.org/MailNews:Logging) that would probably tell you which account is doing it - and maybe with some luck let us spot what is triggering it.

If you build yourself you'll have a few other possibilities (David, andrew ?) - but I don't know which one would be helpfull.
OK, I've put up the IMAP logfile after about ten minutes, it said "Downloading message 14 of 11 in All Mail". From the Activity Window, it seemed that was for the gijskruitbosch gmail address. The full logfile (zipped up) is at www.doc.ic.ac.uk / ~gck08 / imap.zip (I'd rather not have that botlinked :-)).

I'm not sure what to look for, but it did seem from a casual look over the (20MB!?) textfile that it issued a fetch command for almost every email I've ever received (some 100,000 FETCH lines, anyway) which seemed like a bit more than should be necessary... Not sure what that has to do with this issue, though!
Whiteboard: [has protocol logs]
Gijs: Well, OK. Let me clarify...
[2:28pm] Gijs: The issue I wanted to report was that I'm seeing these really odd numbers in the status bar
[2:28pm] Sander left the chat room. (Quit: And back he spurred like a madman, shrieking a curse to the sky.)
[2:28pm] Gijs: Which seem to be indicative of a bug, in the statusbar thingy if nothing else.
[2:28pm] Gijs: (downloading N of M, where N > M, is weird)
[2:29pm] Gijs: So when I tried to figure out what was causing that, Ludovic told me to enable imap logging, which I did - and the first thing I noticed was that it called FETCH for seemingly *every* single email I've ever had. :s
[2:29pm] prasad joined the chat room.
[2:29pm] Gijs: Which seemed odd, to say the least!
[2:29pm] Gijs: But that could well be a separate issue and not related. 
[2:30pm] _Tsk_: ok so the issue for this bug is about  N> M
[2:30pm] Gijs: Right.
xref bug 515031, reporting count mismatch when reindexing Gmail's "All Mail".
still see this problem with current nightly??

if so maybe bug 517466
Gijs ?
(In reply to comment #8)
> Gijs ?

Yes? :-)

Wayne's problem says that if the issue is still there, it may be related to this other bug... which is confusing, but that meant, to me, that even the current nightly might still be buggy!? Anyway, it was confusing.

Otherwise, I recently removed my GMail accounts from my TB3 install on mac, because they ate up gigantic amounts of harddrive space. Together, some 15GB -- whereas in total there is only about 1.5GB of data in the two accounts. I could accept the ImapMail folders being twice as big due to email being duplicated between labels and All Mail, but 10 times as much storage used seemed stupid to me, so I gave up on it. I was planning to create a new profile and see if that helped, but I haven't tried it so far. If you want, I can re-add the GMail accounts and download a current nightly. Would that give you any new info?
(In reply to comment #9)
> If you want, I can re-add the GMail
> accounts and download a current nightly. Would that give you any new info?

By which I meant, I can also try re-adding them to the old TB2-imported profile.
Ys, if you try a nightly, that would give us more evidence that the bug is fixed. The bug Wayne pointed at is fixed in the nightly builds. And this is a dup of that bug, I believe.
(In reply to comment #11)
> Ys, if you try a nightly, that would give us more evidence that the bug is
> fixed. The bug Wayne pointed at is fixed in the nightly builds. And this is a
> dup of that bug, I believe.

OK. I added one of my accounts, it's sync-ing now (and that'll take a while, I bet). I'll post again if I have some results. Reading that bug, I have a similar problem with the one remaining IMAP account, which is an exchange server, which seems to keep indexing emails, without any actual new mail arriving... Is there a different bug for that?
(In reply to comment #12)

> similar problem with the one remaining IMAP account, which is an exchange
> server, which seems to keep indexing emails, without any actual new mail
> arriving... Is there a different bug for that?

yes . But I thought it was fixed too - Bienvenu can you confirm ?
yes,  Bug 518702 is for Exchange, which reports wildly inaccurate sizes for messages with attachments, so we often have to download them twice, because the act of downloading them makes Exchange calculate the size correctly.
Looks like this is all fixed. Thanks a lot! :-)
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 517466
You need to log in before you can comment on or make changes to this bug.