Firefox is hanging the system on shutdown.

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: apurv_bh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

Firefox is hanging the system on shut down. I closed the firefox and then i clicked on the shut down button. But the system didn't respond. Then i opened task manager and found that firefox process was still running. I tried to shut down the process manually but then my computer hanged. Then i checked my performance logs and found that firefox was delaying the shut down and hanged the system. I installed latest zone alarm software ( free version, not pro) and i think the problem has popped up after that only. The problem has become frequent now. My system gets completely hanged and i have to reboot the system with the help of the power button.
I have copied some information from event log generated...

This application caused a delay in the system shutdown process: 
     File Name		:	firefox.exe
     Friendly Name		:	Firefox
     Version		:	1.9.1.2
     Total Time		:	180012ms
     Degradation Time	:	178512ms
     Incident Time (UTC)	:	03-Sep-09 5:30:11 PM



Reproducible: Always
Firefox is a usermode application and can not hang or crash the system.
You can always kill the Firefox process with the taskmanager and if you can't, it's not a Firefox bug. In that case it's a bug of software running in the kernel mode like for example drivers and that includes the Firewall driver that ZA installs.

The ZA software is known to do something like this, see bug 470849

marking invalid because it can't be a Firefox bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.