Feature request: User controlled width of containers

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
9 years ago
2 years ago

People

(Reporter: r_rom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

I want to request a feature that has been on my mind for a long time.

Some pages display text in containers that are too narrow, and some -- too wide. I want to be able to easily change a width of text I happen to be reading. You may suggest resizing my browser's window, but this isn't convenient often. I often have lots of tabs open (tens of them), and I switch among them from time to time. Because text on different pages requires different widths to be comfortable to read, I'd have to resize the window too often for it to be pleasant. So, I'd like to have a VERY easy and fast way to control the width of a text block on a page. 

The way how MeasureIt extension (https://addons.mozilla.org/en-US/firefox/addon/539) approaches measuring elements comes to mind. I think this would be pretty easy. I would simply draw a rectangle around a fragment of text, and the browser would extend it to the entire container (it may have to go up the hierarchy up to a certain level, which I don't yet know how would be determined).

Reproducible: Didn't try
And a minimum text size? Tools > Options > Content > Fonts & Colors > Advanced > Minimum Font size
(Reporter)

Comment 2

9 years ago
That is a separate issue. Here I am concerned with the width of a text block.
(Reporter)

Comment 3

2 years ago
With the release of the Reader View feature, my request has lost is importance.
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.