ES5 strict mode: function arguments may not be named 'eval' or 'arguments'

RESOLVED DUPLICATE of bug 514575

Status

()

RESOLVED DUPLICATE of bug 514575
9 years ago
9 years ago

People

(Reporter: jimb, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
From ES5 Annex C:

It is a SyntaxError if the identifier eval or arguments appears within a FormalParameterList of a strict mode FunctionDeclaration or FunctionExpression (13.1)
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 514575
You need to log in before you can comment on or make changes to this bug.