Closed Bug 514621 Opened 13 years ago Closed 3 years ago

execCommand(bold | italic | underline | fontname | forecolor | hilitecolor) applies the specified formatting on the BR tags too when styleWithCss is true.

Categories

(Core :: DOM: Editor, defect, P3)

x86
Windows XP
defect

Tracking

()

RESOLVED DUPLICATE of bug 480647

People

(Reporter: dpopa, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

execCommand(bold | italic | underline | fontname | forecolor | hilitecolor) applies the specified formatting on the BR tags too when styleWithCss is true.

Reproducible: Always

Steps to Reproduce:
1. Have line 1<br />line 2 text in midas demo in HTML mode
2. Switch to rich edit mode, select all and apply bold | italic | underline | fontname | forecolor | hilitecolor

Actual Results:  
<span style="font-weight: bold;">line 1</span><br style="font-weight: bold;"><span style="font-weight: bold;">line 2</span>

Expected Results:  
<span style="font-weight: bold;">line 1</span><br><span style="font-weight: bold;">line 2</span>

Bug doesn't reproduce with:
- fontsize command because it uses FONT tag (bug #480647) in css mode.
Priority: -- → P3

This is fixed in Nightly build 2012-04-24, most possibly in Bug 480647.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 480647
You need to log in before you can comment on or make changes to this bug.