Hiding toolbars in fullscreen mode doesn't resize vertical scrollbars correctly

VERIFIED FIXED in mozilla1.9.3a1

Status

()

Core
Widget: Cocoa
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: whimboo, Assigned: mstange)

Tracking

({verified1.9.2})

Trunk
mozilla1.9.3a1
All
Mac OS X
verified1.9.2
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 398638 [details]
screenshot

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090904 Minefield/3.7a1pre ID:20090904030702

Entering the fullscreen mode on OS X and waiting until the toolbar gets automatically hidden creates an empty grey block below the vertical scrollbars. See the attachment.

Steps:
1. Open a web page which let show the vertical scrollbars
2. Enter fullscreen mode (Cmd+Shift+F)
3. Wait until the toolbar is hidden
(Reporter)

Updated

9 years ago
Summary: Hiding toolbars in fullscreen mode creates empty area below the vertical scrollbar → Hiding toolbars in fullscreen mode doesn't resize vertical scrollbars correctly
(Assignee)

Comment 1

9 years ago
This is at least partly caused by bug 451641.
The other part is that fullscreen windows erroneously report they have a resizer.
Assignee: nobody → mstange
(Assignee)

Comment 2

9 years ago
Created attachment 399022 [details] [diff] [review]
v1
Attachment #399022 - Flags: review?(joshmoz)

Updated

9 years ago
Attachment #399022 - Flags: review?(joshmoz) → review+
(Assignee)

Comment 3

9 years ago
http://hg.mozilla.org/mozilla-central/rev/f45fc5899017
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
(Reporter)

Comment 4

9 years ago
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090908 Minefield/3.7a1pre ID:20090908030622

Can a reftest catch such a condition?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
(Assignee)

Comment 5

9 years ago
Reftests don't run in fullscreen mode, so they can't catch it. But a mochitest can catch it. I'll write one when I write the general fullscreen tests.
(Reporter)

Comment 6

9 years ago
Markus, sorry for asking here but would there be any part we have to add manual tests?
(Assignee)

Comment 7

9 years ago
I don't think so, no.
(Assignee)

Updated

9 years ago
Attachment #399022 - Flags: approval1.9.2?

Comment 8

8 years ago
Comment on attachment 399022 [details] [diff] [review]
v1

Simple fix, no regressions on trunk, and fixes a significant bug in a major new feature for Mac OS X. This should go on 1.9.2.
Attachment #399022 - Flags: approval1.9.2? → approval1.9.2+
(Reporter)

Comment 10

8 years ago
Verified fixed on 1.9.2 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b1pre) Gecko/20090922 Namoroka/3.6b1pre ID:20090922041132
Keywords: verified1.9.2
You need to log in before you can comment on or make changes to this bug.