If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PP]button sequence causes crash

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
P3
major
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: Chad House, Assigned: Ramiro Estrugo)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The test #8 page has a form with three buttons in a row labelled
"submit", "reset", and "button".

After loading the page, clicking the buttons in this order:

  1. "button"
  2. "reset"
  3. "submit"

crashes viewer and apprunner (m4). The messages in the console
are:

------------------------------------------------------------

 url=file:///home/chadh/mozilla/m4/res/samples/test8dom.html

 data=?

Gtk-WARNING **: invalid cast from `(unknown)' to `GtkObject'

Gtk-CRITICAL **: file gtkobject.c: line 1037 (gtk_object_get_data): assertion
`GTK_IS_OBJECT (object)' failed.

Gtk-CRITICAL **: file gtkwidget.c: line 1395 (gtk_widget_destroy):
assertion `GTK_IS_WIDGET (widget)' failed.

------------------------------------------------------------

Red Hat Linux 5.1 (2.0.36 kernel) on Pentium 166 with 64 MB RAM and Diamond
Stealth 3D 2000 (ViRGE chipset, 2 MB). Window Maker 0.52.0 and XFree86 3.3.3.1
SVGA server.
(Reporter)

Comment 1

19 years ago
Created attachment 35 [details]
stack trace

Updated

19 years ago
Severity: critical → major
Summary: Button sequence causes crash → [PP]button sequence causes crash

Comment 2

19 years ago
under nt 4, i don't see a crash (using the april 15 m5-series build).
(Assignee)

Updated

19 years ago
Assignee: karnaze → mcafee

Comment 3

19 years ago
linux specifc bug.

reassign to ramiro@netscape.com

Updated

19 years ago
Assignee: mcafee → karnaze

Comment 4

19 years ago
Why was this assigned to XPToolkit?  reassigning to karnaze, since it is a crash
in forms widgets on Viewer as well as AppRunner. cc ramiro

Updated

19 years ago
Assignee: karnaze → ramiro

Comment 5

19 years ago
Reassigning to Ramiro.

Comment 6

19 years ago
cant reproduce this on a apr 21 build.
(Reporter)

Comment 7

19 years ago
Tried Apr 20 Linux build -- it defaults to GFX widgets rather than native. No
crashes using either widget type, although using native widgets I do see the
following message four times at the console on form submit:

Gtk-CRITICAL **: file gtkwidget.c: line 3800 (gtk_widget_add_events): assertion
`!GTK_WIDGET_NO_WINDOW (widget)' failed.
(Assignee)

Updated

19 years ago
Target Milestone: M6

Comment 8

19 years ago
cant reproduce this for now.

marking m6.

Comment 9

19 years ago
this could be a gtk 1.2.0 specific bug.  will look at.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 10

19 years ago
cant reproduce, marking worksforme.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
looked at this using red hat linux 5.2, build id 1999052008. i can't get it to
crash.
You need to log in before you can comment on or make changes to this bug.