Tests not installed after upgrade+restart

RESOLVED FIXED in 0.3

Status

Mozilla Labs Graveyard
Test Pilot
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: Jono Xia, Assigned: Jono Xia)

Tracking

Details

(Assignee)

Description

9 years ago
To reproduce:

1. Click on the link to the new XPI on AMO to upgrade an existing TP install to 0.2.0.

2. Browser restart.

3. Click on taskbar icon: The tasks are not listed there.

Expected behavior:  Should have two tasks registered and listed in the menu.

4. Restart the browser again.

5. Now everything works.

???
(Assignee)

Comment 1

9 years ago
Discoverd the reason -- on the first restart after installing the extension, the top window is the add-ons manager.  TestPilotSetup._getFrontBrowserWindow returns this, but it doesn't have a .getBrowser() method so then things fail horribly.
(Assignee)

Comment 2

9 years ago
It actually wasn't what I said in the comment above -- it was something even dumber -- I had getFrontBrowserWindow.getBrowser() instead of getFrontBrowserWindow().getBrowser().  Fixed in http://hg.mozilla.org/labs/testpilot/rev/35136608ded7 and released in Test Pilot 0.2.1.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.