Wrong username results in "Weave failed to connect to the server."

RESOLVED DUPLICATE of bug 518022

Status

Cloud Services
General
RESOLVED DUPLICATE of bug 518022
8 years ago
8 years ago

People

(Reporter: Mardak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
At least with the default serverURL, it responds 404 and makes the client try with no cluster. So then when it tries to verify login..

2009-09-04 12:04:31	Net.Resource         DEBUG	GET request for https://auth.services.mozilla.com/user/0.5/EdTest100/info/collections

That results in 404 which the server isn't expecting because that's not part of the user api and not what the client is expecting either.

Should the user api require that WEAVE_REGISTER_STORAGE_LOCATION is set correctly? Then if the server responds 404 for the node check, we know the user doesn't exist?
We should talk about this whole flow - it was kind of last-minute this way and I don't think it's optimal.

I believe we need to have two variables - one for user lookup and once for storage, but I can be convinced otherwise.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 518022
You need to log in before you can comment on or make changes to this bug.