Status

P1
major
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: mary, Assigned: mozwebqa)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Hi all:  We need some help QA'ing the Mozilla Service Week Facebook Connect App.  It's currently implemented on stage in 3 areas:

1) Registration - https://mozillaservice.stage.mozilla.com/auth/create/en_US
2) Pledge your hours - http://mozillaservice.stage.mozilla.com/tell_us/your_pledge/en_US
3) Share your story - http://mozillaservice.stage.mozilla.com/tell_us/your_stories/en_US

Few things to note:

* The app is currently in English-only.  We're working on localizing it for the different locales.
* It will broadcast over your FB account :)   

Here's what it should look like and the messages that it should send:

1) Caption on this FB connect app: Share your thoughts about Mozilla Service Week.

2) App name:  Mozilla Service Week

3) Prefilled message: Join me!

4) "Volunteer" registration message: ______has signed up to make a difference with Mozilla Service Week.  

5) When someone registers to "Get Help": ______ has signed up for Mozilla Service Week. See how you can help. [link: http://mozillaservice.org/] (We didn't go over this one, but I adjusted it to remove the gender-specific pronoun)
6) Sharing a story (http://mozillaservice.org/tell_us/your_stories/en_US): This will share a link and text from the story on FB.

7) When someone submits both pledge & completed hours:______is making a difference with Mozilla Service Week. __ volunteer hours have been pledged & ___ volunteer hours have been completed!  

8) When someone submits completed hours:
______is making a difference with Mozilla Service Week.___ volunteer hours have been completed!  

9) When someone submits pledged hours:

______is making a difference with Mozilla Service Week.
 ___ volunteer hours have been completed!  

Please let me know if you have any questions.   Staging information is as follows:

> http://mozillaservice.stage.mozilla.com/
> username: moservice
> password: b3th3diff

Thanks!
I received this error message when trying to sign up:

Warning Message

An error was detected which prevented the loading of this page. If this problem persists, please contact the website administrator.

system/core/Kohana.php [528]:

file_put_contents() [function.file-put-contents]: Only 0 of 2657 bytes written, possibly out of free disk space
Stack Trace

    * system/core/Kohana.php [528]:

      file_put_contents( application/logs/2009-09-07.log.php, 2009-09-07 21:04:53 -07:00 --- debug: Global GET, POST and COOKIE data sanitized
      2009-09-07 21:04:54 -07:00 --- debug: Session Cookie Driver Initialized
      2009-09-07 21:04:54 -07:00 --- debug: Session Library initialized
      2009-09-07 21:04:54 -07:00 --- debug: Auth Library loaded
      2009-09-07 21:04:54 -07:00 --- info: Updating en-us to en_US
      2009-09-07 21:04:54 -07:00 --- debug: putenv on en_US.utf8 <pre>(boolean) 1</pre>
      2009-09-07 21:04:54 -07:00 --- debug: setlocale en_US.utf8 output <pre>(string) en_US.utf8</pre>
      2009-09-07 21:04:54 -07:00 --- debug: binddomainout <pre>(string) /data/www/mozillaservice.org/web/application/locale</pre>
      2009-09-07 21:04:54 -07:00 --- debug: MySQL Database Driver Initialized
      2009-09-07 21:04:54 -07:00 --- debug: Database Library initialized
      2009-09-07 21:04:54 -07:00 --- debug: Cache Library initialized
      2009-09-07 21:04:54 -07:00 --- info: METERING postauth/save
      2009-09-07 21:04:54 -07:00 --- info: Dealing with 
      2009-09-07 21:04:54 -07:00 --- info: Updating en-us to en_US
      2009-09-07 21:04:54 -07:00 --- debug: putenv on en_US.utf8 <pre>(boolean) 1</pre>
      2009-09-07 21:04:54 -07:00 --- debug: setlocale en_US.utf8 output <pre>(string) en_US.utf8</pre>
      2009-09-07 21:04:54 -07:00 --- debug: binddomainout <pre>(string) /data/www/mozillaservice.org/web/application/locale</pre>
      2009-09-07 21:04:54 -07:00 --- debug: Auth Library loaded
      2009-09-07 21:04:54 -07:00 --- info: email opt in was ok_to_contact
      2009-09-07 21:04:54 -07:00 --- info: user okay to email is now 1
      2009-09-07 21:04:54 -07:00 --- info: =DB= SELECT COUNT(*) AS `records_found`
      FROM `users`
      WHERE `email` = 'william@virginia.edu'
      2009-09-07 21:04:54 -07:00 --- info: =DB= INSERT INTO `users` (`email`, `full_name`, `username`, `password`, `ok_to_email`, `locale`, `country`, `user_type`) VALUES ('william@virginia.edu', 'William', 'william@virginia.edu', '19d79757b35f2b90a42b62d0eee132da3aae816313a30526ef', 1, 'en-us', 'USA', 'V')
      2009-09-07 21:04:54 -07:00 --- info: =DB= SELECT `roles`.*
      FROM `roles`
      WHERE `roles`.`name` = 'login'
      ORDER BY `roles`.`id` ASC
      LIMIT 0, 1
      2009-09-07 21:04:54 -07:00 --- info: =DB= SELECT `role_id` AS `id`
      FROM `roles_users`
      WHERE `roles_users`.`user_id` = 45
      2009-09-07 21:04:54 -07:00 --- info: =DB= SELECT `roles`.*
      FROM `roles`
      WHERE `roles`.`name` = 'login'
      ORDER BY `roles`.`id` ASC
      LIMIT 0, 1
      2009-09-07 21:04:54 -07:00 --- info: =DB= UPDATE `users` SET `logins` = 1, `last_login` = 1252382694 WHERE `id` = 45
      2009-09-07 21:04:54 -07:00 --- info: =DB= INSERT INTO `roles_users` (`user_id`, `role_id`) VALUES (45, 1)
      2009-09-07 21:04:54 -07:00 --- error: Failed to send Welcome email to william@virginia.edu
      , 8 )

    *

      Kohana::log_save(  )

Comment 2

9 years ago
From the error it looks like the server has run out of disk space.

Comment 3

9 years ago
The bug mentioned in comment #0,is blocking all QA efforts

Comment 4

9 years ago
I get the same error as Comment #1 
An error was detected which prevented the loading of this page. If this problem persists, please contact the website administrator.

On all 3 links
1) Registration - https://mozillaservice.stage.mozilla.com/auth/create/en_US
2) Pledge your hours -
http://mozillaservice.stage.mozilla.com/tell_us/your_pledge/en_US
3) Share your story -
http://mozillaservice.stage.mozilla.com/tell_us/your_stories/en_US

Comment 5

9 years ago
I just tried now. I registered and pledged and both actions worked.

Comment 6

9 years ago
I tried again useing windows vista 
I was not able to create a accounts with the top 3 links of mary post

my errors

FROM `users`
WHERE `email` = 'jamey@spreadfirefox.com'
2009-09-08 04:38:32 -07:00 --- info: =DB= INSERT INTO `users` (`email`, `full_name`, `username`, `password`, `ok_to_email`, `locale`, `country`, `user_type`) VALUES ('jamey@spreadfirefox.com', 'jamey', 'jamey@spreadfirefox.com', '96b1cedf936ef1b3350beaed4ccb1eddf8170d02c71852d850', 0, 'en-us', 'USA', 'V')
2009-09-08 04:38:32 -07:00 --- info: =DB= SELECT `roles`.*

Comment 7

9 years ago
I'm getting the error now too. Definitely looks like a disk space thing. I notice that if I click on the link provided at the top left of the error I can continue fine (I'm registered, have logged on, etc). I then pledge, get the same error. Click on the link on that error page and I can continue, etc.

Updated

9 years ago
Depends on: 513773
OS: Mac OS X → All
Hardware: x86 → All

Comment 8

9 years ago
Already logged in at FB
Registration for moservice - no problems
Post registration FB Connect window - Entered credentials and logged into FB via FB Connect Window, could not proceed with sharing, was prompted to enable cookies although mozilla.com and FB cookies where already enabled. Re-enabled FB cookies on FB, hit refresh on moservice and lost the FB connect window.

Same as above for pledging hours 

Sharing story via FB Connect - FB Connect was (obviously) connected to FB and ready to share but the contents of the FB Connect window were not being displayed properly.
Hit refresh, lost the share window, chose to Edit the story, Submit (Share on Facebook enabled), got the same error page that others mentioned, hit back, (I forget if I had to hit Submit again or just refresh) hit Share, successfully shared on FB although the only info displayed on FB from moservice was mozillaservice.org as the title and mozillaservice.org for "Source:"

I'm going to register a new account and see if the cookies issue reappears. I have 3rd party cookies turned off and just add exceptions as needed. Not sure if that was problem.

See the attachments

Comment 9

9 years ago
Created attachment 399290 [details]
Cookies are not enabled

Comment 10

9 years ago
Created attachment 399291 [details]
FB Connect window contents not displayed properly

Comment 11

9 years ago
Created attachment 399292 [details]
Shared story on FB - No details

Comment 12

9 years ago
New moservice account

"Sharing a story (http://mozillaservice.org/tell_us/your_stories/en_US): This
will share a link and text from the story on FB."
No text from my story was posted on FB. Just the moservice title and URL

I pledged 640 hrs but 20 was posted to FB when sharing

Can't figure out how to get back to pledge hours page to add "completed hours"

Comment 13

9 years ago
New moservice account

"Ken registered for Mozilla Service Week to make a difference."
I registered to "Get Help" and as Ken-S. Though I can understand why the -S was dropped.

5) When someone registers to "Get Help": ______ has signed up for Mozilla
Service Week. See how you can help.

Comment 14

9 years ago
(In reply to comment #12)
> No text from my story was posted on FB. Just the moservice title and URL

This is because Facebook cannot access the story page to get the details to display due to the authentication required on the staging server.
(Reporter)

Comment 15

9 years ago
Is there a work around to test this?  Thanks!

Comment 16

9 years ago
Ah yes. That explains (indirectly) the cookies issue too. 
I forgot that I was on stage so I was not accepting cookies from it initially.

Comment 17

9 years ago
(In reply to comment #15)
> Is there a work around to test this?  Thanks!

It only affects the story link submission. The pledges, etc should all work as Facebook doesn't attempt to retrieve the link.

Is it possible to disable the staging authentication for the story pages during testing? That would be the easiest workaround.
I've filed an IT Bug#515297 to disable it for 24 hours.
We need to do another L10n push, so I've added a new config:
fb-enabled and set it too false.

1) Facebook should be disabled on stage until we get this L10n release out
2) Please test more and let me know if you see any bugs with the fb-enabled flag.
ie. no JavaScript or other errors have crept in.

Thanks!
(Reporter)

Comment 20

9 years ago
Hi all: This should all be enabled again.  Do you feel comfortable with this going live on the en-US site at the very least?
Well, I typed some test titles and content into http://mozillaservice.stage.mozilla.com/index.php/tell_us/your_stories/en_US?mode=thanks and submitted it, and didn't see either come through once I shared with Facebook; literally just the link.

Comment 22

9 years ago
(In reply to comment #21)
> Well, I typed some test titles and content into
> http://mozillaservice.stage.mozilla.com/index.php/tell_us/your_stories/en_US?mode=thanks
> and submitted it, and didn't see either come through once I shared with
> Facebook; literally just the link.

Was this during the time period that the authentication for the app was disabled?

Comment 23

9 years ago
If you want to see how the story link should appear, go to Facebook, and near the status input box choose 'Link' in the 'Attach' section.

For an URL, use a story URL on the live mozillaservice.org site. eg: http://mozillaservice.org/activity/story/201/en_US

Click attach and Facebook will retrieve the page and show details. This is what the box in the staging server should look like if Facebook can retrieve the story page on the staging server.

Note you can cancel out of the above steps and don't need to actually post the story to your Facebook stream.
Assignee: nobody → mozwebqa
I don't know how to check; my comment 21 was from when I tested.  I assumed that it's on due to comment 20.

Here's a screencast that might help clear things up: http://screencast.com/t/fQ6axoHc
Severity: normal → major
Priority: -- → P1
Authentication is turned off in stage.

If I paste 
http://mozillaservice.stage.mozilla.com/activity/story/35/en_US
into http://www.facebook.com/home.php
it properly loads the link and can get the title, photo, etc.

Hope that helps.

Comment 26

9 years ago
The problem from the screencast in comment 24 is the URL being passed to Facebook is:

http://mozillaservice.org/activity/123

(Where 123 is the story number, It disappeared to fast on the screencast to get the actual number).

This story exists on the staging server, not on mozillaservice.org so it cannot be seen by Facebook. What should that URL be?
Chris please svn up.
I fixed 2 issues:
1) FB Connect on Add and Edit only
2) Updating a story was failing, I've fixed by having it look for $data['story_id']
(In reply to comment #27)
I checked in a fix for this. Facebook will now post a story. 

Note: It pulls from production, so when you create story 123, it will post production's 123 into your profile.
(In reply to comment #27)
Changed hostname to use $config['hostname']. This seems to work.

Your stage story show now show up on your profile.
I can't (fully) confirm step 5. from comment #0 of this bug. It's all ok but the message in the fb post. In comment #0 , step 5 of this bug, it says that the post on fb should say :

> ______ has signed up for Mozilla
> Service Week. See how you can help. [link: http://mozillaservice.org/]

but I can only get:
> ______ has signed up for Mozilla Service Week.
Actually, I get _______ registered for Mozilla Service Week to make a difference.

sorry for double post.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
marking as verified fixed
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: mozillaservice.org → mozillaservice.org
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.