Up arrow won't work in menus, and other related arrow problems in menus

CLOSED WORKSFORME

Status

()

Core
XUL
P3
normal
CLOSED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Aaron Leventhal, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)
BuildID:    2000061408

Click on a menu, get the highlight on an item. Down arrow works, up arrow 
doesn't.
Also, you have to use the mouse to highlight an item in the first place. That's 
bad for keyboard only users. You should be able to down arrow from the menu bar 
to the first menu item in a menu. When right clicking, the first item should be 
automatically highlighted.

Comment 1

18 years ago
Um, this works correctly with 2000090508 on win2k/win98 and linux (mac menus
don't work this way for any application). (Is that build ID of 061408 correct?). 

I can use either ALT+letter or click on the top-level menu, and then use up and 
down arrows to set focus to any menuitem. Arrow keys also work for context 
menus.

I don't get the last point: context menus on windows don't typically select
any item automagically (or am I missing that point). 

(Assignee)

Comment 2

18 years ago
Sounds like several separate problems here, should be separate bug reports.
1) up arrow:  works for me using today's verification build on Win98
2) first highlight: I can hit alt, then cursor keys to highlight any menu item.
3) Right click: don't have my Windows UI guidelines here, but our behavior is
same as Windows desktop.
->wfm
Status: NEW → RESOLVED
Last Resolved: 18 years ago
(Reporter)

Comment 3

18 years ago
Strange, I can't hit Alt+letter, get to a menu and arrow down with 061408.
Up arrows won't work at all for me in menus.
I'll try downloading a binary to see if that works.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
06/14 was nearly three months ago. I don't, offhand, recall the state of 
key navigation in menus at that moment in time :-]
(Reporter)

Comment 5

18 years ago
Okay, works for me in binary download. Thanks.
Status: VERIFIED → CLOSED
(Assignee)

Comment 6

18 years ago
Its good practice in general to reproduce problems in recent builds before
filing bug reports, saves lots of time all around.

Comment 7

18 years ago
Somehow the WORKSFORME resolution got lost. Reopening...
Status: CLOSED → REOPENED

Comment 8

18 years ago
... re-resolving as WORKSFORME ...
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
and marking CLOSED again.
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.