[Mac] Full Screen button not shown in 'Show: Text' mode

VERIFIED FIXED in Firefox 3.7a1

Status

()

Firefox
Toolbars and Customization
--
minor
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: KENZ (Kenji Irie), Assigned: mstange)

Tracking

({verified1.9.2})

Trunk
Firefox 3.7a1
All
Mac OS X
verified1.9.2
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3.6 +
in-litmus +

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; ja; rv:1.9.3a1pre) Gecko/20090904 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; ja; rv:1.9.3a1pre) Gecko/20090904 Minefield/3.7a1pre

Full Screen button displays incorrectly (it takes some space, but doesn't show text 'Full Screen') with toolbar mode 'Show: Text' (changed from Toolbar customize dialog) in full screen mode.

Reproducible: Always

Steps to Reproduce:
1. Open Toolbar customize dialog
2. 'Restore Default Set'
3. Select 'Show: Text' then close the dialog.
4. Make window full screen (with shortcut 'Command + Shift + F')
5. Look rightmost area of the toolbar.
Actual Results:  
There is space for the full screen button, but doesn't show text.

Expected Results:  
Full screen button with text 'Full Screen' or so.

Updated

9 years ago
Blocks: 505699
(Reporter)

Comment 1

9 years ago
Sorry, in full screen mode, the button should show 'Restore' text.
(Assignee)

Comment 2

9 years ago
Good find!
Assignee: nobody → mstange
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Hardware: x86 → All
Version: unspecified → Trunk
These two rules are necessary.

http://hg.mozilla.org/mozilla-central/annotate/2600b11db971/browser/themes/winstripe/browser/browser.css#l1527

toolbar[mode="text"] > #window-controls > toolbarbutton > .toolbarbutton-icon {
 display: -moz-box;
}

toolbar[mode="text"] > #window-controls > toolbarbutton > .toolbarbutton-text {
 display: none;
}
(Reporter)

Comment 4

9 years ago
Created attachment 398839 [details]
Screenshot shows the bug.
(In reply to comment #3)
> These two rules are necessary.
> 
> http://hg.mozilla.org/mozilla-central/annotate/2600b11db971/browser/themes/winstripe/browser/browser.css#l1527
> 
> toolbar[mode="text"] > #window-controls > toolbarbutton > .toolbarbutton-icon {
>  display: -moz-box;
> }
> 
> toolbar[mode="text"] > #window-controls > toolbarbutton > .toolbarbutton-text {
>  display: none;
> }

This actually belongs in browser/base/content/browser.css.
Component: Theme → General
QA Contact: theme → general
(In reply to comment #5)
> (In reply to comment #3)
> This actually belongs in browser/base/content/browser.css.

Is this also so?

http://hg.mozilla.org/mozilla-central/annotate/2600b11db971/browser/themes/winstripe/browser/browser.css#l1523

toolbar[mode="text"] toolbarbutton.chevron > .toolbarbutton-icon {
 display: -moz-box; /* display chevron icon in text mode */
}
(Reporter)

Comment 7

9 years ago
(In reply to comment #2)
> Good find!

Originally Kuden-san finds this. I've just reported it. Good catch!
Component: General → Theme
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #3)
> > This actually belongs in browser/base/content/browser.css.
> 
> Is this also so?
> 
> http://hg.mozilla.org/mozilla-central/annotate/2600b11db971/browser/themes/winstripe/browser/browser.css#l1523
> 
> toolbar[mode="text"] toolbarbutton.chevron > .toolbarbutton-icon {
>  display: -moz-box; /* display chevron icon in text mode */
> }

Not necessarily, there's also a toolbarbutton-menu-dropmarker which a theme might want to display instead.
Component: Theme → General
Component: General → Toolbars
QA Contact: general → toolbars
(Assignee)

Comment 9

9 years ago
Created attachment 399020 [details] [diff] [review]
v1
Attachment #399020 - Flags: review?(dao)
Comment on attachment 399020 [details] [diff] [review]
v1

>+#navigator-toolbox[inFullscreen="true"] #fullscr-toggler,

this should use ">"

>+toolbar[mode="text"] > #window-controls > toolbarbutton > .toolbarbutton-icon {

this should use #nav-bar
Attachment #399020 - Flags: review?(dao) → review+
(Assignee)

Comment 11

9 years ago
http://hg.mozilla.org/mozilla-central/rev/1e2b034670d9
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
Markus, why do we still show the button while we are in text mode? Shouldn't all buttons be displayed as text?
(In reply to comment #12)
> Markus, why do we still show the button while we are in text mode? Shouldn't
> all buttons be displayed as text?

I also think so. 
However, I think that it is another bug.
Minimize, restore and close originally mimicked window controls (they still do on Windows and Linux), and those are always just icons.
Ok, that would make sense.

Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090908 Minefield/3.7a1pre ID:20090908030622
Status: RESOLVED → VERIFIED
(Assignee)

Comment 16

9 years ago
(In reply to comment #12)
> Markus, why do we still show the button while we are in text mode? Shouldn't
> all buttons be displayed as text?

That would definitely make sense since we don't mimic window controls on OS X.
Attachment #399020 - Flags: approval1.9.2?
(In reply to comment #16)
> That would definitely make sense since we don't mimic window controls on OS X.

Does it mean we should file a new bug on that? Probably I cannot interpret your answer correctly.
Comment on attachment 399020 [details] [diff] [review]
v1

a192=beltzner
Attachment #399020 - Flags: approval1.9.2? → approval1.9.2+
Flags: blocking-firefox3.6+
Verified fixed on 1.9.2 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b1pre) Gecko/20090922 Namoroka/3.6b1pre ID:20090922041132
Flags: in-litmus?
Keywords: verified1.9.2
https://litmus.mozilla.org/show_test.cgi?id=9534 added to litmus.
Flags: in-litmus? → in-litmus+
Blocks: 522140
Probably we should have been reopened that one a month ago. Now that it is a bit too late I have filed bug 522140 as a follow-up.
Summary: [mac] Full Screen button displays incorrectly in 'Show: Text' mode → [Mac] Full Screen button not shown in 'Show: Text' mode
You need to log in before you can comment on or make changes to this bug.