E > F:first-child is stronger than class="foo"

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Tobias Burnus, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Hi this is with 2000-09-05-08/Linux

goto the the attachment. The red 'x' should be centered, but it is left aligned.
E > F:first-child over-rules the <f class="foo"> part.
If I remove the (in this case unnecessary) "E >" the 'x' is centered.

Expected: class="" overrules always the selector.
(Reporter)

Comment 1

18 years ago
Created attachment 14072 [details]
Testcase as in bug report described
:first-child is a pseudo-class, and has the same specificity as a class.
Marking invalid.  See CSS2 section 6.4.3
( http://www.w3.org/TR/REC-CSS2/cascade.html#specificity ), which shows that the
selector 'tr > th:first-child' has specificity 12, and 'th.default' has
specificity 11.  If the latter is changed to 'tr > th.default', then the
alignment changes.

Marking bug INVALID, since our current behavior is correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
VERIFIED per dbaron
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.