focus to other element fires mouseout event

RESOLVED DUPLICATE of bug 513684

Status

()

Core
XUL
P1
major
RESOLVED DUPLICATE of bug 513684
9 years ago
9 years ago

People

(Reporter: Kazuho Okui, Assigned: roc)

Tracking

Trunk
Points:
---
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090905 Minefield/3.7a1pre

When an element focus moves from one to the other (e.g. display tooltip, hide/show an element), framework send "mouse out" event to previous element if the elements on a xul:panel element.

This affects all tooltiptext on xul:panel element.

Reproducible: Always

Steps to Reproduce:
1. create a xul:panel and put an element with tooltiptext
2. Launch firefox and hover mouse to the element

Actual Results:  
It appear tooltip text few second later, and immediately disappear because displaying tooltip send mouseout event to the element

Expected Results:  
It shouldn't send mouseout event to the original element.

I attached sample XUL code which added small text on statusbar. click "Click here" text to open xul:panel.

Statusbar tooltip works fine. However, tooltip on panel doesn't work.
(Reporter)

Updated

9 years ago
Flags: wanted1.9.2?
(Reporter)

Comment 1

9 years ago
Created attachment 398904 [details]
Sample code for reproduce tooltip bug
(Reporter)

Updated

9 years ago
Flags: blocking1.9.2?
(Reporter)

Comment 2

9 years ago
This happens all platform (Windows, Mac, and Linux)
OS: Mac OS X → Windows XP
Version: unspecified → Trunk
Is this a recent regression?  If so, when did it regress?

Comment 4

9 years ago
Regression wiondow:

Works:
http://hg.mozilla.org/mozilla-central/rev/f2a58ffcd00c
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090721 Namoroka/3.6a1pre ID:20090721044139

Broken:
http://hg.mozilla.org/mozilla-central/rev/02f8bf10f441
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090722 Namoroka/3.6a1pre ID:20090722042136

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f2a58ffcd00c&tochange=02f8bf10f441
Flags: wanted1.9.2?
Flags: blocking1.9.2?
Flags: blocking1.9.2+
Priority: -- → P1
This bug is resolved by the patch on Bug 513684 if I understand the bug correctly.  If not, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 513684
(Reporter)

Comment 6

9 years ago
I downloaded latest Minefield

firefox-3.7a1pre.en-US.mac.dmg	17-Sep-2009 05:57 	 23M

from

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ 

and run attached xpi. It seems bug is still in there.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

9 years ago
Not yet fixed,
The issue is in 
http://hg.mozilla.org/mozilla-central/rev/3079370d6597
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090917 Minefield/3.7a1pre ID:20090917041912
Bug 513684 hasn't been checked in yet on mozilla-central ...  My apologies if I jumped the gun a bit on marking it as a duplicate.
Whiteboard: [depends on bug 513684]
Assignee: nobody → roc
Bug 513684 was checked in a couple days ago.  Does this still appear on trunk?
(Reporter)

Comment 10

9 years ago
It seems working appropriately on 

firefox-3.7a1pre.en-US.mac.dmg	28-Sep-2009 06:28 	 23M

Is this patch also going to apply Fx 3.6 branch?
(Reporter)

Comment 12

9 years ago
great. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Whiteboard: [depends on bug 513684] → [depends on bug 513684][needs 1.9.2 landing]
Bug 513684 was landed on 1.9.2 this morning.  As I said in comment 5, if I understand the bug correctly it is fixed by that patch.  Per comments 5 and 10, changing to duplicate for recordkeeping.
status1.9.2: --- → beta1-fixed
OS: Windows XP → All
Hardware: x86 → All
Resolution: FIXED → DUPLICATE
Whiteboard: [depends on bug 513684][needs 1.9.2 landing]
Duplicate of bug: 513684
You need to log in before you can comment on or make changes to this bug.