Html select control not properly displayed when embedded in SVG via foreignObject

RESOLVED DUPLICATE of bug 403445

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 403445
9 years ago
9 years ago

People

(Reporter: Tangui LE PENSE, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.13) Gecko/2009080315 Ubuntu/9.04 (jaunty) Firefox/3.0.13
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.13) Gecko/2009080315 Ubuntu/9.04 (jaunty) Firefox/3.0.13

When embedding a <select/> html control in an SVG document via the foreignObject element, it is not displayed properly.

Moreover, it is impossible to select an item and no event (change in the example) is fired.

Reproducible: Always

Steps to Reproduce:
1. Go to the given url
2. try to select a different color in the select control
Actual Results:  
The list is not displayed at the good place. It is impossible to select another item in the list. No event is fired.

Expected Results:  
The behavior of the select element should be the same as when embedded in html content.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403445
You need to log in before you can comment on or make changes to this bug.