Random characters (hex codes?) rendered in page

VERIFIED FIXED

Status

()

Core
Networking
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Karl Johan Kleist, Assigned: Gagan)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build ID: 2000090508 / RH 6.2

RECIPE:

1. Visit "http://www.microwarehouse.se/"

2. In the field labelled "Sök produkt:", enter "cinema"

3. Be amazed by the amount of junk, like " 144 26f 34 21b", or "12 0", that
   is rendered all over the page.

   The page is rendered fine by NS 4.72, IE5 (win) and Opera 4.02 (win).

   (The HTTP header at the top is bug 43729, I assume. )
(Reporter)

Comment 1

18 years ago
Reporter agin. Sorry, no CSS here I think. The content of
<style type="text/css"> was commented away.

Comment 2

18 years ago
Confirmed on the Mac. I'm going to attach a log of the dialog with the server. 
Note that the hex characters *are* in the stream. For instance, look at lines 
243/245: they contain the strings "2e" and "d3". Same thing in lines 310 and 331 
with the strings "144" and "26f". Someone told me that this is normal with what 
is called HTTP chunks. I don't know anything about that. Reassigned to Networking 
like bug 43729.

Assignee: pierre → gagan
Status: UNCONFIRMED → NEW
Component: Style System → Networking
Ever confirmed: true
OS: Linux → All
QA Contact: chrisd → tever
Hardware: PC → All
Summary: Random characters (hex codes?) rendered in page using CSS → Random characters (hex codes?) rendered in page

Comment 3

18 years ago
Created attachment 14129 [details]
HTTP session log

Comment 4

18 years ago
Seems to be fixed in Linux Build 2000092909 and CVS branch pulled 10/5/00.
Reporter, please re-verify bug.
(Reporter)

Comment 5

18 years ago
Reporter here: Yeah: looks fine in build 2000100321 / Linux
(Assignee)

Comment 6

18 years ago
wont be surprised if somehow this was related to the events problem we had. 
Either way alls well that ends well. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
verified rh6 2001010510
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.