a small html causes SeaMonkey to crash

RESOLVED DUPLICATE of bug 512834

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 512834
8 years ago
8 years ago

People

(Reporter: Tom Schneider, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.23) Gecko/20090823 SeaMonkey/1.1.18
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.23) Gecko/20090823 SeaMonkey/1.1.18

I came across an old web page I'd stored and it killed SeaMonkey.
I have trimmed it down to the attached file.

Reproducible: Always

Steps to Reproduce:
1. launch SeaMonkey on the file
2. wait for crash ...

Actual Results:  
SeaMonkey's window disappears and the panel for reporting bugs appears.

Expected Results:  
SeaMonkey probably should display the page.
(Reporter)

Comment 1

8 years ago
SeaMonkey was blown away merely by reading the file as an attachment!
Firefox is not affected.
Safari is not affected.
(Reporter)

Comment 2

8 years ago
<html>

<head>
<title>SeaMonkey Killer Page</title>
</head>

</tr></table><APPLET  codebase="/im/" CODE="mnCheckIM.class" WIDTH=1 HEIGHT=1 MAYSCRIPT id="mnCheckIM"><param name=HOST value='www.somewhere.com'><param name=URL value='/im/checkim.asp?uid=32166863-3853-4614-9F10-FDAE79EF9689&key=3206949'><param name=DELAY value=20000><param name=ShowDebugMessages value='false'></APPLET></body></html>

</html>
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
Sorry I couldn't put it in as an attachment, there it is as comment #2.
(Reporter)

Comment 4

8 years ago
Created attachment 399168 [details]
killer file

I'm trying to add the killer file again as an attachment ...
(Reporter)

Comment 5

8 years ago
Ok, I don't understand why the first time I read the attachment in it died.
But it did attach as you can see.

DO NOT CLICK ON THE ATTACHMENT UNLESS YOU ARE PREPARED TO CRASH SEAMONKEY!
(In reply to comment #4)
> killer file

Unable to reproduce crash with Sm 1.1.18 on MS Win-XP SP3, with JRE 1.6.
Load error is displayed in Java Console, and blank is displayed in Sm's Tab.

What version of Java SE do you install? SDK? JRE?
Java Plug-In which your Sm uses is one installed by newest Java you installed?
  1. Set plugin.expose_full_path=true via about:config at URLbar,
     and check path/version via about:plugins at URLbar
  2. Reset plugin.expose_full_path=flase for safety.

New problem after upgrade to Wm 1.1.18? (No problem when Sm 1.1.17?)

(A) Java version displayed in Java Console 
> Java Plug-in 1.6.0_16
> Used JRE version 1.6.0_16-b01 Java HotSpot(TM) Client VM
(B) Error message in Java Console when the page is loaded by Sm 1.0.0.18
> load: Class mnCheckIM.class is not found.
> java.lang.ClassNotFoundException: mnCheckIM.class
>  at sun.applet.AppletClassLoader.findClass(Unknown Source)
>  at java.lang.ClassLoader.loadClass(Unknown Source)
>  at sun.applet.AppletClassLoader.loadClass(Unknown Source)
>  at java.lang.ClassLoader.loadClass(Unknown Source)
>  at sun.applet.AppletClassLoader.loadCode(Unknown Source)
>  at sun.applet.AppletPanel.createApplet(Unknown Source)
>  at sun.plugin.AppletViewer.createApplet(Unknown Source)
>  at sun.applet.AppletPanel.runLoader(Unknown Source)
>  at sun.applet.AppletPanel.run(Unknown Source)
>  at java.lang.Thread.run(Unknown Source)
(C) Error message in Java Console when the page is loaded by Fx 3.5.2
> load: Class mnCheckIM.class is not found.
> java.lang.ClassNotFoundException: mnCheckIM.class
>  at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
>  at java.lang.ClassLoader.loadClass(Unknown Source)
>  at java.lang.ClassLoader.loadClass(Unknown Source)
>  at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
>  at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
>  at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
>  at java.lang.Thread.run(Unknown Source)
> Caused by: java.io.IOException: open HTTP connection failed:https://bug515127.bugzilla.mozilla.org/im/mnCheckIM/class.class
>  at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
>  at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
>  at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
>  at java.security.AccessController.doPrivileged(Native Method)
>  ... 7 more
> Exception: java.lang.ClassNotFoundException: mnCheckIM.class

Comment 7

8 years ago
Tom, what version of Mac OS X are you using?

Comment 8

8 years ago
(In reply to comment #7)
> Tom, what version of Mac OS X are you using?

If you're running 10.6 there are known issues with the Java Embedded Plugin.
(Reporter)

Comment 9

8 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > Tom, what version of Mac OS X are you using?
> 
> If you're running 10.6 there are known issues with the Java Embedded Plugin.

Yes Stefan, I just upgraded to 10.6 this last weekend.

I trimmed the example a lot, but didn't go beyond that line.  The file was generated by a web site years ago and I happened to look at it.  Surely it was not a problem years ago.

Comment 10

8 years ago
Tom, the JEP plugin that ships with seamonkey 1.1.x and runs Java applets is not compatible with 10.6. See https://bugzilla.mozilla.org/show_bug.cgi?id=512834#c7 for a solution (manually upgrade the plugin).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 512834
(Reporter)

Comment 11

8 years ago
This solved bug.  THANKS!!
You need to log in before you can comment on or make changes to this bug.