Closed Bug 515134 Opened 10 years ago Closed 6 years ago

The closed tab doesn't exist in the "Recently closed Tabs"

Categories

(Firefox :: Session Restore, defect, minor)

3.5 Branch
Sun
Solaris
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 497730

People

(Reporter: vicky.sun, Unassigned)

Details

Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9.1.2) Gecko/20090831 Firefox/3.5.2

Steps to Perform:

See http://quality.mozilla.org/preparing-for-session-store-testing for instructions to set up your test environment for session store tests.

   1. Open an article from Latest Headlines bookmark in a new tab
   2. Quickly close the tab (you need to be very quick - tab needs to close before a title appears in the tab)
   3. Click History menu > Recently Closed Tabs
   4. Click the item listed
	
Expected Results:
   1. The closed tab should be listed with the page title (NOT "Loading...")
   2. Clicking the item should load the page in a new tab

Actual Results: 
   1. The closed tab doesn't exist in the "Recently closed Tabs"

Please refer to the test case on Litmus:
https://litmus.mozilla.org/show_test.cgi?id=7792
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090908 Minefield/3.7a1pre

It is impossible to close the tab before the title appears in the tab. There is not enough time for that. Moreover, the menu is still hiding the tab. When the menu collapses, the page is already there. 
So not reproducible here on my Windows computer.
This issue sounds like bug 497730.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497730
You need to log in before you can comment on or make changes to this bug.