If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Copy Feature To Clipboard Does Not Work

RESOLVED DUPLICATE of bug 527662

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 527662
8 years ago
8 years ago

People

(Reporter: Mike, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1

1.  I am also using Firefox 3.5.2 and the copy feature works fine
2.  I can copy information from Firefox 3.5.2 to the compose feature of SeaMonkey or to a form like this in SeaMonkey.
3.  However I can not copy anything from a SeaMonkey web page or the SeaMonkey composer to anyplace on SeaMonkey other than what was originally in the clipboard. 
4.  Once a clipboard has information the copy feature in SeaMonkey does not replace that information on any subsequent use of the copy feature.
5.  I cleared cache, cleaned my registry and rebooted but there was no change.


Reproducible: Always

Steps to Reproduce:
1. Right click mouse or click on copy on the Edit menu
2. Click Paste with the mouse or from the edit menu
3. Pasted word or words does not change from what was in the clipboard before executing the copy command.

Actual Results:  
The text that was on the clipboard before the copy command got posted to the destination site in SeaMonkey.

Expected Results:  
SeaMonkey should have copied to the clipboard the highlighted information in SeaMonkey when I clicked Copy and then when I clicked the Paste command SeaMonkey should have pasted that information to the chosen destination. 

No problems along this line being experienced with any other software including Firefox 3.5.2.  

I can even copy whatever information I want from Firefox 3.5.2 into SeaMonkey and the copied information will change and paste properly in SeaMonkey.

The problem appears to be that when you use the Copy command in SeaMonkey it does not update the Clipboard.  The Paste command seems to properly paste whatever information is on the Clipboard..
(Reporter)

Updated

8 years ago
Keywords: helpwanted
Priority: -- → P3
Version: unspecified → Other Branch
(Reporter)

Comment 1

8 years ago
Thanks

Comment 2

8 years ago
I'm unable to reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090906 SeaMonkey/2.0pre current nightly build. Clipboard content copies and pastes fine from browser to either mail composition or composer windows, and from composer to a mail window.

So, if it was a bug in 2.0b1 it may be fixed by now, or I'm missing something to reproduce this which may cause the clipboard to not function properly.
Keywords: helpwanted
Priority: P3 → --
Version: Other Branch → Trunk

Comment 3

8 years ago
Unable to reproduce and no further feedback from the reporter, thus closing.
->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 4

8 years ago
Other reports show that Copy may be blocked by an anti-virus product. Reporters are encouraged to check this, see bug 525601 or https://wiki.mozilla.org/SeaMonkey:StatusMeetings:2009-12-01#SeaMonkey_2.0_Final
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 527662
You need to log in before you can comment on or make changes to this bug.